[BUG LOGGED] TCA Quadrant & AddOn problem with SU5

for me there is also another problem …every 20 sec i have a control freeze for about 10 seconds…

1 Like

Just downloaded hotfix and our problem has not yet been addressed.

1 Like

Can confirm the issue has not been fixed since today’s hot fix. Annoying!

Kind of Standard reply From the Support

German below

Thank you for contacting us regarding your concern.

In that case, I’d bite you to completely uninstall and then reinstall the driver.
Then download the latest drivers “Drivers - Package 2020_TFHT_5 + Firmware” from our support page and install them:

Please also update the firmware of the product now:

If you have any questions about the update, please have a look at the following recording:

Now please test the device in the Windows operating system as follows:

  1. Press the “Windows” key + “R” key
  2. Enter “joy.cpl” and click “OK”
  3. When the device is recognized, go to “Properties”
  4. Test all functions of the device.

Please do not hesitate to let us know if these instructions have not solved your problem.

Kind regards

Danke dass Sie uns hinsichtlich Ihres Anliegens kontaktiert haben.

In diesem Fall würde ich Sie bitten, den Treiber komplett deinstallieren und neu zu installieren.
Danach laden Sie die aktuellsten Treiber „Drivers - Package 2020_TFHT_5 + Firmware“ von unserer Supportseite runter und installieren diese:

Bitte aktualisieren Sie jetzt auch die Firmware des Prodktes:

Falls Sie zu dem Updates Unklarheiten haben sollten, schauen Sie sich bitte folgende Aufnahme an:

Testen Sie jetzt bitte das Gerät im Windows Betriebssystem wie folgt:

  1. drücken Sie die “Windows” Taste + “R” Taste
  2. geben Sie “joy.cpl” ein und klicken Sie “OK”
  3. wenn das Gerät erkannt wird gehen Sie auf “Eigenschaften”
  4. testen Sie alle Funktionen des Gerätes.

Bitte zögern Sie nicht uns mitzuteilen, wenn diese Instruktionen Ihr Problem nicht gelöst haben.

Mit freundlichen Grüßen

Daniel, Ihr Ansprechpartner bei Thrustmaster.

Is anyone here who knows how I can rollback to previous update of MSFS 2020 because after latest one my Airbus TCA Officer Pack is going crazy (Sidestick also Throttle Quadrant Add-on is working only as they want to).


Currently, there is no way to rollback to previous update, it is a shared online platform for everyone. So everyone needs to be on the same version.

You can have a look at my setup and follow it. This setup works with every function on the FBW A32NX.

I made it from the current Default profile, then move around some of the bindings, removing the ones with issues while also setting new things differently. But overall, it’s still based on the current default profile.


Put your mouse in Legacy mode. I could use the mouse to start engine 1 and I got airborne without my previous issue of losing 80-100 kts of air speed and then never being able to recover. I climbed to FL29000 but now the issue was FL. ATC always saw me at a different FL than I was flying at. This sim has really turned into a joke. More game then sim, relying on graphics alone. ASOBROKEN

Yeah, ATC seems to not take the transition altitude into account. On my flight yesterday, I had to reset my altimeter to NOT use standard. So if the ATC told me that I’m 300 feet above my assigned altitude, I changed my altimeter to make it so that I’m 300 feet above the assigned altitude, and once there I pull the altitude knob to have it descend to the “current” assigned altitude and that usually silenced the ATC from bothering me anymore…

Until that is, you’re flying into another airspace with a different barometric pressure, the ATC will follow that instead and you need to reset your altimeter again.

I guess for now, I’ll just have to fly in Weather preset rather than Live.

I’m having the same issues, the fixes LS above helped to solve the engine problems, but still since the update the displays randomly shut down in all aircraft.

I’ve found that flicking the Eng 1 switch to off starts the displays up again (shows initializing) but then the engine shuts down.

It looks like something else is bound to that switch, but I can’t find what it is.

Anyone else have this problem, and resolved it?

Again, prior to this update, the quadrant + add on pack had been working fine.

Note: Have also tried the instructions provided by thrustmater for reinstalling the drivers and firmware, but problem still occurs.

Thank You for support but in my case I tried everything including fresh install for MSFS 2020 also all firmware updates for Airbus TCA Office Pack. Nothing is working right, no throttle on TCA Add-On only on Sidestick, sesitivity curves after reset looks crazy , no HUD switch working for changing cam view and more issues .
So only chance is to waot fpr anoyher hotfix like last one to ver. even nothing change 4 me. Perhaps better choice is to manual edit config files for both controllers.
All the best.

1 Like

Well by default the sidestick will also have the throttle bound to the slider. You need to remove this from the sidestick. I myself rebind the throttle axis on the sidestick into Brake Axis instead. That way, my sidestick slider operates as an analog braking for managing better taxiing speed, while at the same time avoiding conflicting commands from two hardware.

While I build my Throttle profile based on the default, my sidestick however, start a new profile from scratch. That way, I can apply the commands that I want to, while at the same time avoiding any conflicting commands.

1 Like

Thanks for the tip AC3EX2467, as soon as I get the chance I’ll look into that.

I have the same problem. Someone suggested it could have something to do with the right mouse button but haven’t looked into that yet. Either way they shouldn’t expect us to be beta testers.

ASooooBo frustrating to have everything ticking along nicely, and following an update (that should be aimed at improving the software) to have it all fall apart. Not being able to fully utilise the TCA as per pre-update is a real pain. Come on ASOBO, test these things before releasing updates that cannot be rolled back!


Hi. I have the same problem and The simulator gets stuck.

Switch the mouse mode to Legacy
Path: General options/Accessibility/Cockpit interaction system to legacy.
Hope it works!


Engine Crank and Engine IGN/Start button won’t work, me too.

When IGN/Start mode is on at TCA hardware, I can’t move engine mode switch to IGN/Start with mouse.

Does anybody have the same issue ?

I got mine to work, including the autobrake. Just make sure you have the same mappings as I do that I posted above, and also make sure you don’t have any other hardware bound to the same engine switches. 1 command 1 binding.

You can have multiple commands mapped to a single binding… But never but multiple bindings to a single command.

Well, same bug with the TCA Eng1 Switch here.
(But I don‘t think it‘s that game-braking compared to stuff we had in other SU‘s)

Guess it is the same procedure as with other SU‘s before for me since there are more bugs (with the AP HDG/SPD Push/Pull in the A32NX) witch are not that easy to solve:
-Find out about all the stuff that is not working
-Report bugs
-Wait (at least if the bugs require more complex workarounds)
-Download the bugfix one month later
-enjoy again

That’s what I’m used to since I simply do not wan‘t to do all the big Troubleshooting and spend hours in doing so.

Simple Workaround for the Eng1 switch without changing any assignments is:
-make sure Eng1 Switch is in the OFF Position
-flip the switch via mouse in the sim
-leave the TCA switch in the OFF Position

1 Like

Yep. I can confirm Neo’s findings.
Works all like a charm for me.

1 Like