[BUG LOGGED] XBOX Series X: Thrustmaster T.Flight HOTAS One - button assignment works incorrectly

Will the upcoming hot fix resolve any of the Xbox Thrustmaster issues? Seems that it is more focused on PC problems introduced in the last upgrade. Is anyone at Thrustmaster working on this?

2 Likes

Really, it does not get better! I found yet another bug with the settings of the HOTAS One:

You probably used your Xbox controller to change the sensitivity settings, but did you tried it with a mouse ?
… well, you will have a bad surprise: it works badly, it really is rubbish! :rage:

The problem is not with my mouse, because when I change the sensitivity of the Xbox controller, it works. But when we try to do the same thing for the HOTAS One, this is what happens:

If we drag the cursor, for example for the dead zone, the adjustment is done (the curve changes), but the value remains at zero. The headband is also not colored blue:

And now, if we click on it, the value is displayed … but we can set the cursor to zero and the displayed value remains (here 55%):

It’s a shame, the bugs are certainly inevitable, but here it is obvious: it has never been tested properly. So far, my score is one bug per day with this one :rofl:

1 Like

Same issues here: button mapping up the creek, sensitivity settings can not be saved, internal camera scrolls straight up for no reason and refuses to be re-centered, etc., etc.,

1 Like

Does this work fine out of the box? As in with standard button config it is preset with?

Is it just mapping that is the major issue?

Please confirm.

For me no issues out of the box with the defaults. But they are not ideal and find myself using both the flight stick and the controller together. I use the stick for flying and the controller for looking and setting the autopilot. A first class mess.

2 Likes

Yup. Let’s face it, the HOTAS 1 simply does not work even though the default bindings are apparently locked in. Change the bindings? Not so easy if you are a novice to the game plus you’ll need to put 12 hours aside to both navigate the clunky dashboard and to work out which binding applies to which function, if its even available. Very frustrating

1 Like

Usb ports back or front make no difference to my game. HOTAS f1 joystick still doesn’t work correctly. I can fly but very few of the assigned buttons actually register and if they do it’s usually completely wrong regardless of usb port. Hopefully these issues will be addressed sooner rather than later

1 Like

I don’t have any issues with the default button bindings, though not ideal and would be better if custom bindings were possible. My biggest issue is sensitivity settings are not saved. Once these problems are fixed then using the Hotas 1 with the flight simulator will be very enjoyable.

2 Likes

https://youtu.be/Lf4y_Ke_iKo this video allowed me to map whatever actions to whichever buttons on my Hotas One that I wanted to and to also clear out any conflicting actions. A great video, honestly.
After watching this video I have ZERO issues with my Hotas one. I could care less about the bad mapping now. Only the sensativity settings need to be reset if you restart the game. That takes about 45 seconds… Lol

4 Likes

I am new to Xbox and queued to get the Xbox Series X on launch day to find out I’d have to wait months for Flight Sim 2020, the only game I really wanted to play having had MS Flight Sims years ago. Now I’ve bought the Hotas one as it was recommended on the Flight Sim site and now I can’t even find the correct button to turn the engines on! Feeling really stupid having paid all the $$ and can’t use it how I expected.

I thought these things were working out of the box? I’m not talking about mapping or anything but just standard out of the box?

I thought it would just replicate the controller settings??

Can you still use the controller alongside this?

Confused…

The basic steering is working, but not all buttons are properly mapped. When trying to configure manually, not all options are shown, so you cannot put all functions that you find on the regular controller onto the stick. You can use a regular controller alongside the stick but this is far from optimal and - frankly - a bit embarrassing that this is not working properly out of the box.

As noted on the other thread, this does not work for everyone. Glad it works for you.

Yes it works generally speaking but you can’t remap any buttons and sensitivity settings reset when you turn the game off. You can use a controller too, in fact you have to if you want to touch any instruments in the cockpit.

When the sim asks you to release brakes and prompts you with the button number, its wrong. I had to set certain buttons, like engines on as I never found anything on the HOTAS One that did that. Its just frustrating but resigned to the fact, I have to spend time mapping buttons. If you choose an assignment when you are already in the air then Joystick works fine to turn the plane and the throttle works.

Yes I see what you all mean now

Things like B1 for start engine actually registers as B5 for example…

So currently only the basic inputs work correctly.

A lot of the other buttons when you scan register as something else? That’s the major issue yeah?

Yes, I didn’t have this issue last week but tried playing today and mapping is just a mess. Registering all kinds of incorrect buttons

Same here. “Search” function mis-identifies pressed buttons, and manually binding functions to buttons either has no impact (pushing the mapped button doesn’t do anything in the game) or functions wind up bound to the wrong buttons.

Has anyone figured out how to configure Toggle Pause with the T.FLight Hotas One on your XBox? It is assigned to the menu button (to the right of the Xbox logo). Pressing that button pauses (similar to that button on my Xbox controller, pulling up the Options menu), but when I press it again nothing happens. To get back to flying, I have to press the menu button on my XBox controller.

Yet another question to those of you, who have worked a little bit with the TM Hotas 1:
Has anyone worked out, how to unassign the hat switch from the menu navigation and fixed views, and assign it to panning views (look up, down, left, right - as it “should be”)?
Yesterday, I tried to help a friend of mine set up his new hotas for Xbox X, and - coming from the PC side of flightsim - I found it almost unplayable without the ability to pan my view around the cockpit. Of course you can bind keyboard commands, but that’s …ummm… not very ergonomical, to say the least. We have tried a lot of things, but didn’t find a solution at all…