[BUG LOGGED] XBOX Series X: Thrustmaster T.Flight HOTAS One - button assignment works incorrectly

XBOX Series X:
Buttons assignment works incorrectly for Thrustmaster T.Flight HOTAS One.
I’m trying to assign button to any function in the input recognize mode - when I press any button - incorrect result is listed. For example - I press “A” but “B1” is listed in the field. For each button incorrect results provided after button pressing. Same for combination of buttons - wrong combinations appears in the field, not that one was pressed. Also in the list for manual choose there is no “F1”, “A” listed insted of it.
MSFS 1.18.12.0
Zendesk ticket - 111950

My HOTAS One isn’t functioning on my Series X either. Most of my buttons just don’t work at all. For example when it says hit F2 to go back from a menu screen it doesn’t work. Hitting Y to end a discovery flight doesn’t work. Can’t even re-map because it doesn’t recognize button presses.

3 Likes

Same problem here. I was able to use the defaults even though I don’t like them. However no my Xbox just crashes to the dashboard when trying any flight planned in the world map.

2 Likes

Same problem here. Specifically, I could not complete the very first flight lesson because I was instructed to select the B4 button in order to resume a camera position in the cockpit. I attempted to change the assigned button and found that the B4 button was dually assigned to both the camera view and to flap control.

2 Likes

I have the exact same problem. Hope they fix it soon.

My Hotus one was not working until I plugged it into the usb in the back of the Xbox. Now it works perfectly. Strange.

1 Like

I forgot to mention I first tried the usb in the front

I agree. Several mis-maps of the default Controller and HOTAS keys, particularly tricky during the Flight Training when you have to try to guess what it could be.

2 Likes

Exactly the same issue here - cannot even use the flight stick at this point because it isn’t mapped and won’t map properly.
It would be nice if the controller worked instead but that has a whole other host of issues.

Yes same problems here, glad I am not alone, hope to be able to use the hotas correctly soon.

I’m posting a workaround so at least the Flight Training can be completed.

2 Likes

Hi, I too am having the same problems. Are you supposed to always have a controller attached? I note there is no headphone jack on the flight stick so you need a controller attached.
Also, the rocker buttons on the throttle dont seem to be registered at all.
And… how do you trim?
It seems like a lot of issues yet Thrustmaster arent saying anything? It doesnt even list teh XBOX version of the game on its support site - yet is promoting it as teh best to use with the xbox???

1 Like

I thought that initially, but I found that if you held the end of the rocker down it did slowly trim.
(I tried it in level flight while I was not under pressure)

They work just slowly. I lowered the sensitivity curve and they are usable, not perfect but usable.

I don’t know if anyone else knows this, but it looks like this issue is in the known issues list on the FAQ:

" Xbox players using the Thrustmaster T.Flight HOTAS One: Mappings on the Controls screen does not match the labeling of the buttons and axes on the peripheral.

Workaround:
Though what you see on the screen is incorrect, if you make an assignment through scanning it will be accurate. Do not use the drop-down to create your mapping."

1 Like

Huh? So if something is ‘actually’ B and you scan B back in, it will say ‘B’… hmmmm

I tried that last night and it doesnt work as for example (buttons X and A on the controller both come up labeled as B1 when you do a scan to try and map them, also the Pedel on the throttle front and the B button along with the F2 button on the stick all come up as F2 when scanning), so I am not sure how they can say that is a work around. O and he hat switch UP also scanns as F2, Left scans as Y, Down scans as A, and Right scans as B2. Those are just some of the notes I took.

1 Like

If it only worked like it shows then we wouldnt have this thread.

1 Like

If you chose the default mapping then it works like this for me.
All buttons are screwed up when trying to map it yourself, but this is the default.