Xbox Series X- HOTAS One Issues

Nice of them for them to finally acknowledge the issue.

Currently all the “Official” Xbox support peripherals have some pretty glaring bugs/glitches and compatibility issues, it’s really shame that Microsoft’s biggest launch of the year so far couldn’t even go as far as to test the peripherals to make sure they actually work with the game before they start advertising and selling the peripherals to consumers from their storefront.

You guys are lucky though, at least they’ve committed to fixing this. I just spent $400 on the Razer Turret (the official keyboard and mouse combo for Xbox flight sim, as MS so claims), just to find out it’s missing some pretty essential keys for controlling and flying the aircraft (mainly the numpad, as it’s a TKL keyboard).

At least you guys finally got a response out of them, I’m not stuck with a $400 paperweight with no word from Asobo or Microsoft, but hey at least the mouse works!

What a joke.

3 Likes

Hey buddy… You’re right, it is a joke. Five minutes of someone’s time testing could have indicated these issues pre-launch and how easy in the context of the resources thrown at this sim to have sorted the peripherals? This isn’t some easily missed nuance. I literally watched Jorg Neumann (head of MSFS) on Youtube spouting hyperbole about how the Hotas was fully supported and ready to play with at launch, as well as other controllers. He just seems like a Peter Molyneux level Walter Mitty character to me now.

1 Like

No, it’s even more fun than that…

To be sure that the bug was not related to internationalization, I’ve changed the language to “EN-US”, then look at my “PERSONNEL” set:


Nice! I can see the “BRAKES” key here. :slightly_smiling_face:

So, I switched back to language “FR-FR”:


Hey, what a surprise! now the “BRAKES” key is visible. :astonished:

I didn’t change anything to the PERSONNEL set.
So, this mean that something is wrongly initialized, and the first time (when your simulator is not in EN-US language) this option is badly displayed.

There is also something strange to notice:
When switched to “FR-FR” language, the BRAKES (FREINS) option is at the top of the list.
When switched to “EN-US”, this option is at bottom of the list.
Why this difference ? the list is not sorted, so there is no reason for this option to change of place.

It look very unstable, and very weird if the keys are displayed randomly.

2 Likes

Interesting find, thank you!
One thing you will notice with the assigned parking brake button: It will also move the view one step or fluid if pressed when using external camera though there is no such assignment (it does activate/deactivate the parking brake the same time with each press). This is really totally f… up :wink:

It is called the Xbox Breakaway Cable.

Like this: https://www.amazon.co.uk/Fosmon-Replacement-Microsoft-Controllers-Controller/dp/B009I0VK2U/ref=asc_df_B009I0VK2U/?tag=googshopuk-21&linkCode=df0&hvadid=310568533429&hvpos=&hvnetw=g&hvrand=16607826486106558242&hvpone=&hvptwo=&hvqmt=&hvdev=c&hvdvcmdl=&hvlocint=&hvlocphy=9045999&hvtargid=pla-492366371959&psc=1

1 Like

Please vote for hotas mapping issue here:

If you’re brand new, you earn votes by reading posts while logged in. Specifically, you need to:

  • Enter 5 topics
  • Read 5 posts
  • Spend at least 15 minutes reading posts
3 Likes

The problem extends to not permit to save the sensitivities of the HOTAS when finally found a proper setting on sensitivities of their stick and pedals axis, if close the simulator when reopen you lose the adjustments, please fix this guys.

6 Likes

A quick hack to save your Thrustmaster T.Flight Hotas One Flight Stick on Xbox Series S/X, if you use the ‘Quick Resume’ feature you will not need to keep changing your stick settings in the controls panel.

1 Like

Has anyone tried selecting pc mode instead of xbox? The reason i ask is no matter which i select it works fine on both xbox and pc?

Pc mode doesn’t work with my hotas on Xbox.

I have the same problem mapping thrustmaster t flight hotas on the xbox. It’s a nightmare. :weary:

No problem setting up my X52 on the PC.

By the way …thrustmaster throttle control is pretty bad, no hold on movement. Too much softness…

But this way you will get a timeout of the session of the marketplace which results in any buys to fail…

I’m having the same button mapping issues as well as sensitivity settings. I suppose we have no choice but to wait.
Another concern that perhaps someone can help me with: can you even use the cursor toggle with the hotas? I looked through all the possible settings and couldn’t find anything. It would mean that you have to use a controller to manually touch instruments and access the panel up top that pops up when you push down on left stick.
Hopefully I’m just missing something because it would suck to have no way to only use the hotas.

I mapped the action that you get by depressing the left joystick down(cursor toggle) to a button on the Hotas throttle. There’s a video on YouTube that showed me how… https://youtu.be/Lf4y_Ke_iKo

1 Like

Thanks! I’ll give that a try.

It didn’t work for me. I watched the video. Tried two different bindings and neither worked. So you’re able to click a button on use the cursor just like you’d clocked the LS with the controller? To then touch knobs or fiddle with the menu on top?
I’m stumped.

Its really disappointing… Due to the HOTAS not working I haven’t touched the game in 10 days… The button mapping is sooo poor especially considering that is being called out as a supported peripheral.
I know it works to some extent, but constantly guessing and checking for the right buttons is not the way I want to play this game.

1 Like

Yes, I was able to map the left click button to one of those 3 uttons on the bottom of the throttle… I then use my mouse to move around and click on controls… I now have NO need or the controller while I play MFS.

1 Like

It’s been weeks now, and still no hot-fix. The Hotas is not therefore ‘Supported’ and wasn’t from the start by virtue of this forum and others.
I’m past caring to be honest. Had I known, I would not have bought the Hotas.
It’s the principle of it. MSFS lied about their peripheral support and happily just took the money based on a deceit. Gamers/Simmers treated like second-class customers and alpha testers, as usual.

2 Likes

I’ve been going crazy trying to get this dumb hotas and FS to at least being usable. I’ve now got the Razer Tartarus V2 my thought being what I can’t do on one I’ll do on the other. Great… but no… I have given up for now its a stinking mess for now. All I got was the headache I’m nursing right now.

1 Like