Thrustmaster HOTAS One not recognizing button presses

A lot of other users have the same problem. There’s something wrong with the button mapping profile of this controller.

Real button on T flight // what happen in FSim :
F2 = B4
B2 = B2
F1 = A
B1 = B5
:arrow_up: = F2
:arrow_down: = A
:arrow_left: = Y
:arrow_right: = B2
Throttle = F2
select button = B
start button = Y
Next = A
Prev = X
B5 = B5
Y = B2
B = F2
A = B1
X = B1
B3 = B3
B4 = B4
back throttle button = F2


Is this something that will be fixed by an update or is this something inherently wrong with the flight stick


I plugged in my new HOTAS One (new like purchased Sunday) to my Series X and I’m getting practically no control response. Tested my HOTAS on Star Wars Squadrons Sunday or Monday night and had no control issues. Was really looking forward to the Series X release too. Hopefully its a bug they fix quickly whether its Thrustmaster or Xbox

Has a fix been found? My flight stick is practically useless on this game, currently stuck in a menu and the b button doesn’t even back me out, have to grab my controller just to exit menu’s

I’ve tried all 3 USB ports front and back, no luck. I hope a quick hotfix solves this problem. Really disappointed as I was looking forward to playing this for awhile now. I know I can still play with a regular controller, but it’s really not the same.

This is so annoying. Baught this stick to use with series X on flight Sim as it was listed as compatible on the official website and I can’t even do the tutorial because it’s asking me to press L3 to get into cursor mode.

It tells me F2 is for landing gear but It doesn’t work, B activates landing gear.

Cannot back out of menus pressing B half the time and if I pause the game I cannot un pause it unless I get the controller out.

Please fix this.

1 Like

My older Side winder has the same issue after this update. Can map button 4 to toggle the spoilers and nothing happens, can map it to another button that works with flaps, but wont for the spoilers. Thanks Asobo…

Same issue here, some of the defaults work like the trim when using the rocker, however if I try create a new controller profile and assign the rocker as a key, it recognises it as one of the other buttons and will not recognise it as an axis like it does in the pc version.

So, I tried the workaround that was suggested in the known bugs thread in the support tab. Still no luck. Still won’t acknowledge any button presses when trying to remap controls. Scanning does not work. Button presses still not recognized.



These are how the standard controls are mapped now

1 Like

Thanks CashBeast

1 Like

Nice find, the Thrustmaster support page only shows the layout for the pc version.
They also only show they support the one named game at the moment on the series x/s.

It is strange that the preset buttons down include all the buttons including the Xbox menu button as being programmed.

There is another post here about the hotas mapping issue, which has garnered a little bit more attention. Please vote here to increase visibility for the bug:

If you’re brand new, you earn votes by reading posts while logged in. Specifically, you need to:

  • Enter 5 topics
  • Read 5 posts
  • Spend at least 15 minutes reading posts
1 Like

I had same issue with scanning but got scanning to work. Problem was that focus was not in the blank scanning field so when clicking a button nothing appeared to be scanning. I am using mouse and the stick. If you can use a mouse try it - probably can focus with controller on the field as well. Just make sure focus is on the empty scan field before you click a button. This is not to say there are not problems even when scanning. I was assigning cockpit left, right, up, down, left up, right up, left down, right down to hat switch. Found you can’t scan the hat switch itself - you need to select from the drop down joystick pov selections if you want to map the hat switch. All the pov directions work except if you map the up/right view to the up/right pov in the drop down then the ‘A’ button on the throttle acts like the up/right function! The mapping of the up/right does NOT warn you or anything so you find out about it when you test the mapping in game. So can’t use ‘A’ button with up/right mapped with the hat. Then I found I can’t assign the A button and X button to separate tasks as the game gets confused and thinks they are the same button. So I am using the up/right and not using the ‘A’ button for anything. I’ve mapped other buttons and used one of them for the parking brake (which default config is A button). Spent 2-3 hours this morning on debugging Thrustmaster and fs2020. This is sad QC. Hope it all gets sorted out eventually.

BTW - I was mapping the 8 directions of the hat so I can get smooth in cockpit directional viewing like I am used to in prior PC versions of FS. I don’t like the snap to views. Plus the default config only snapped view to front, back, left, and right even though the hat has 8 directions. Anyway smooth scrolling view in cockpit does work good if you have the patience to set it up (


Thanks for the link, I’ll try to do that.

Moi pareil , quand je souhaite assigner des touches pour mes commandes de vol , soit il ne les prend pas en compte , soit il inverse le bouton , ex ; je veux assigner F2 et après en fin de compte c’est le X qui est pris en compte et ça ne marche pas vraiment. Je pense que ce périphérique n’est pas 100 % compatible.

The issue of the confused button mappings for the Thrustmaster T.Flight HOTAS One on Flight Simulator 2020 was known at least a year ago, when people were reporting it on the PC version.

It is a known issue currently on the Xbox version, as reported at flightsimulator[dot]zendesk[dot]com. The workaround offered there is

Though what you see on the screen is incorrect, if you make an assignment through scanning it will be accurate. Do not use the drop-down to create your mapping.

I haven’t put this to the test yet, but am posting it here in case it proves true and helps.

Should I just return this to bestbuy? It claimed to work on the series x but it won’t even let me map buttons. The Xbox controller is more useful.