Bush trips not saving progress or legs

I know this is an issue on PC but not seeing anyone or a few on XBOX… I am doing bush trips on Series X, specially Rijeka to Santorini. Tried already 3 or 4 times and it is not flagging the legs as completed. I am able to land on the runways, stop the ariplane and saw the dialog saying “Leg completed”. I was on leg 4 or 5 when leave the game but the next time I was forced to start over from the beginning. No way it saves the previous legs… xbox

Please vote this up
SU5/SU6 and Bush Trips - Bugs & Issues / Online Services & Activities - Microsoft Flight Simulator Forums

1 Like

I did many bush trips (before the SU6) and had, like many people, problems with the validation of the legs. I established a personnal rule that works well (er… well, before SU6, I haven’t tried again since).

I noticed that often, the problems came when I went to the next leg by clicking on “continue” when the popup endscreen was displayed. And often, I also got a CTD just after the takeoff of the next leg.

So, here is the rule that I always use for the bush trips:

  • Fly the leg, land and when the popup screen is displayed, choose “return to main menu” instead of “continue”.
  • From the main menu, select your profile and open the logbook. Check that the leg is well registered: it should have a departure and arrival airports (sometimes, “vicinity” works also). But most important, you should have “1” both in the takeoff and in the landing columns. If the takeoff or landing is at “0”, then the leg is not valid and must be refly.
  • To continue the next leg, open the bush trip menu, choose the trip and click on the next leg.

Never use “continue” at the endscreen. Always check that the leg has been correctly registered in the logbook, before to fly the next.


Failure to record completion of legs in bush trips supposedly fixed in GOTY release. Still does not seem to work in Germany trip eg. at Ohlstadt.

The San Juan Island Run still the same behaviour. Leg was succesfully notified, but next time I enter it is not recorderd. Other bush flights were working fine in this respext :face_with_raised_eyebrow:

the log sais 1 takeoff and 2 landings. Something I can do to correct it?

Maybe it is a solution…

  • Go to the support options

  • change something like unlimited fuel on/off,

  • save the change you have made and look for the save indicator (small circle) in the lower right corner

  • if needed change it back to the state you had before

  • save again

I’ve made the experience the small circle is very important if you want to keep your bush trip and log book progress.

Yes. That workaround works! But it’s not normal! And very annoying!