C172S Max RPM way off

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Brief description of the issue:

When going to Max throttle in the C172S, max RPM only reaches 1300.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Jump in the aircraft and take it to max throttle

PC specs and/or peripheral set up if relevant:

Build Version # when you first started experiencing this issue:

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Did you set the air fuel mixture proper according to altitude?

1 Like

Yes. I was on the ground and doing my run up. Mixture was full rich.

What airport? I tried at some random airport in Africa and got throttle up to 2300 and change. Took and flew a right pattern fine and landed easily.

1 Like


Try running the engine at full rich on the ground at Daocheng Yading Airport (14380 feet)


Do you have the same issue if you follow the OP’s steps to reproduce it?


Provide extra information to complete the original description of the issue:

Full rich mixture works when you’re at sea level or relatively low altitude. One of the possible issue you’re facing is that you set full rich, on ground but at a location where temperature and altitude are high. In this condition, the mixture should be leaned to have the maximum power (and rpm). That’s Density Altitude. I have personally no issue reaching max rpm on the regular MSFS Cessna 172. Let us know the result of a test where you set full rich on a field at sea level with a outside temperature around 15 to 20 degrees Celsius. Obviously, it could be another reason. For example, joystick/throttle settings.

@Vincent1064 i was at Key West airport and it was with the G1000 C172. I didn’t have any issues with the other C172. Everything worked just fine. I also use the Xbox controller since I don’t have a throttle or joystick.

Do you have any mods installed?

@Lgdeaf, @MRTNAIRLINES, I see you voted for this topic. Which 172 variant are you seeing this on? At what airport and mixture setting are you seeing this at? Do you have any mods installed?

@N316TS I have the NXi Mod, Airport Enhancement Mod, and the Airport Environment Mod. I’m going to a full reinstall to see if that helps. Again the other C172 (non G1000) worked just fine.

I’m sorry for the late reply. Before trying to reinstall the whole sim, I wanted to mention that I believe you can uninstall the 172 by itself:

In Content Manager, if you search for “172 g1000”:

then click the icon that looks like a bulleted list (i.e., the one on the right in this picture):

you should get a search result for the Cessna 172 (G1000):

I’ve never tried it, but you should be able to delete it and then reinstall it without having to reinstall the sim:

1 Like

The non G1000 doesn’t have the new propeller model, maybe it has something to do with it? I don’t see any issues on my side though.

1 Like