Cabri G2 Throttle Overiding Governor

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

no

Have you disabled/removed all your mods and addons?

yes

Brief description of the issue:

when an axis is assigned to “Set Helicopter Throttle Axis” and the governor is engaged, the throttle position fights the governor instead of the governor maintaining engine rpm.

Provide Screenshot(s)/video(s) of the issue encountered:

https://youtu.be/FcKIuhatocQ

Detailed steps to reproduce the issue encountered:

assign an axis to “set helicopter throttle axis” then turn on the governor with the engine running in the Cabri G2.

PC specs and/or peripheral set up if relevant:

i912900k, 64GB 5200, 3080Ti w/850w PS
W10 64bit
Pro-Flight Trainer Puma controls (older G4 Puma)

Build Version # when you first started experiencing this issue:

SU11


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

I have not flown this heli in RL, but my experience with the Robinson R44.

When you are rolling on the throttle, you reach a point where the governor takes over, and it will start rolling the throttle for you. We tend to keep your hand on it, to catch it, if it revs everything up too much, but it tends to settle into flight RPM.

The governor does it own thing, but the Pilot can grab it at any time and apply more power, or roll off.
The gov does not have enough strength to resist the PIC moving it.

This was how we initiated autorotations in the R44’s, and is how I have been doing it with this heli as well. This is also how they are shown in training videos for this helicopter.

I think the issue is there are no force feed back collectives that allow a motor to control the throttle with twisting liek the real one that the user can also twist.

2 Likes

That is exactly my experience in Robinsons as well.

My first though on any easy solution would be to disable the throttle axis when it reaches a certain range and the governor controls the throttle unless the axis is moved out of that range.
That would make it so you could still use the axis to perform autos.

I don’t see the proliferation of motorized throttles for helisim collective peripherals happening any time soon…

1 Like

I found this, too. I think it’s meant to work well, as it has only occasionally overridden it for me. Perhaps it’s hardware dependant?

When I had a throttle axis mapped, I rolled up through 400RRPM and the Governor did ‘catch’ and roll up to 530. I can override the governor as expected, BUT it can do it out-of-the-blue when you don’t want it to. Putting some thought into it, I think it’s a hardware issue where the sim is reading ‘jittery’ control input. So hands (thumb) off of the assigned throttle hat on my X56, I roll on to about half way, but the actual value is jumping around a tiny bit behind the scenes.

It’s almost like the throttle input and/or heli Governor logic needs a dead-zone of sorts. Plus it’s combined with the issue of control sync, so without hardware that physically moves too, the sim’s governor controlled throttle will conflict with your control input. But, like I say, the Gov logic having some sort of dead-zone seems like a solution.

As an aside, I have the same issue with pedals. I’m on an X56 with twist grip, so holding a twist is agony on long flights, so in cruise I (in DCS etc.) pseudo-‘trim’ the pedal input. Tried in MSFS, but like with the Governor, my pitch-roll inputs naturally give a bit of twist which overrides the keyboard ‘trim’ and yeets the heli around back to neutral pedal as my ‘input’ overrides it. Easily solved for yaw twist (widen the centre deadzone), but for governor that will need to be dynamically either side of whatever value your throttle is at when the Gov takes over, rather than just ‘centre’/50% for pedals/stick.

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

version 1.37.19.0

If relevant, provide additional screenshots/video: