Can anyone please help

So…I have had 2 months of trouble free simming…
I have been enjoying this sim and mainly use G/A…
I have however got a problem which has only started in the past 24hrs and dare I say it, since I added some content to the community folder.

My aircraft does not load correctly and after I hit the fly now button, I get a graphical glitch and have to shut down the sim to be able to restart it. This is now happening every session. It happended a couple of times over the past day and I was able to restart the sim which seemed to have reset something and enabled me to load the aircraft fine, but this time no amount of resets is clearing the issue.

When I am in the hanger and change the view to inside the cockpits I also get a graphical issue which I assume is related to the same problem in flight, as my virtual cockpit does not load. Photos attached. I change aircraft and it happens to all of them. I also notice when I change aircraft and shutdown the Sim, when I boot it back up, the aircraft loaded is not the last one I selected but the 172, which is where my problems began today.

I wondered if anyone has seen this issue, knows the cause and what I may do to reset.

I thought maybe my hardware was overcooking but Ive never had this problem in the past 2 months and only since I added liveries and OnAIR to my simulator. I have since deleted all liveries but still get this issue.

Crude photos, apologies. Taken on my phone.

Any advice??

Looks pretty catastrophic!
If you cannot reverse uninstall your mods, your only option may well be a complete reinstall.
Hopefully, wiser heads than mine will come up with a procedure for you.
Good luck.

I’ve run into this problem among a few others, and I really hate to say this, but to correct each issue, the only solution was to uninstall everything then reinstall it. Although give it a bit to see if any others have a, ehm, less time and data consuming solution. Oo

I think you answered your own question.

Remove any files from the Community folder. Move them to say C:\TEMP_Community when MSFS is NOT running.
Re-boot and try again…

If that does not fix it… then its NOT something that was in the community folder, and you have other UNKNOWN issues… so maybe a re-install as a last resort.

If you are going to Uninstall, and re-install, I suggest you wait till tomorrow (10/28/2020) till after todays Patch #5.

1 Like

Do you have facetracknoir installed? That’s been causing a similar problem for others.

See here: MSFS Stopped working - zooms to outer space?

1 Like

Assuming you have the Steam version, If you have the hard drive space, I recommend copying the Packages subdirectories to another spot, that’s the bulk of the 100 GB download (actually about 98 or so), this will save you the interminable re-download and potentially any hiccups therein. You just need to move it back into the same spot it came from when you finish the initial 500MB install of the base program and it starts to download the 100GB. Stop the program when it starts the 100GB download, move the Packages back where it was before, restart the sim, it should recognize the packages with minimal updates downloaded thereafter.

Not sure if this trick works for FS bought through the MS Store. But that’s how all the reviewers got to distribute launch day copies quickly to multiple PC rigs for analysis.

Thanks all

I do have facetracknoir. But it’s not running. I may uninstall it and see.

I am using the Microsoft store version

I delete everything from community folder and it still continues. But this is only addon liveries.

I will wait for after today’s patch and see…but when I’ve had this problem previously it has magically fixed itself and I’m not sure why…

Have you tried the Repair and Reset options on the Windows App itself? That’s a quick no-labor check that might bear fruit.

Well done that man. I loaded the sim. This time with facetracknoir running. And it worked…

I also noticed that when I booted the Sim, it searched for an update. It hadn’t done that at all in the last few attempts. Like it skipped that step.

As soon as I loaded the IR programme and booted the sim it looked for an in game update.

It now seems to be fine…


1 Like

well worth running [ sfc /scannow ]

I did this on my system, when I thought I was having MSFS issues, and it found a few bad system files, and repaired them.

May or may not help, but you should always be able to run sfc /scannow and get a report that all your primary system files are OK .