Can someone try KORD ILS to 28C?

I posted this in Bugs but I never seem to get any action there. Is someone able to try this on the B747? Here is the copy/paste from the bug post:

The last three times I have done an ILS approach to KORD Runway 28C flying the B747-8i, the approach autopilot slowly directs me to Runway 28R. I have the runway landing assist turned on that shows the decent boxes clearly going to 28C, but I see the plane slowly drift to the right and off of the path directly to 28R. Can anyone give this a try? I think each approach I have done to 28C starts at VOGLR navpoint so try that one please!

Here it is again with the A320. Looks like the ILS approach is broken to me.

You have to turn on LS right from the FD button. Then you will see the frequency, the glideslope, localizer etc.

Two things are jumping in.

  1. you did not activate LS on the FCU, so you can’t see the ILS and I don’t know if the AP will then follow it.
  2. you have 28L entered in your FMS, so it’s both wrong, Aircraft position and the ILS frequency for 28L if you never changed it in the MCDU manually. But we don’t know, because due to #1 we actually can’t see the ILS locator on the PFD.
    On the other hand, if the vanilla A320 is as bad as the other airliner, I would recheck this with the FBW A320 dev.

I’m not sure I follow.

On my previous attempts with the B747 the glide path diamonds are centered and I’m on the glide slope, but it takes me to 28R.

This one attempt was with the A320 (which I’m less familiar with) to see if it was something odd with just the B747, but it incorrectly took me to the same runway again.

There is no 26L at O’Hare. It actually says 28L in the display, but that was not entered by me. The flight plan was taken from the World Map ILS 28C approach, and the ATC also is acknowledging 28C.

What’s the ILS frequency you are using?
Btw. the ILS works perfect in the 747.
Not aircraft related.


The vanilla airliner got all the same bad FMS construction, so it could be a problem with the FMS on all airliner. I could recheck this approach later on with the FBW A320.
I corrected my entry to 28L already. Fingertrouble….

I am not familiar with boeing but as written above the setting is wrong for an airbus. You need the fbw airbus and turn on ls and appr. Then you catch the loc and gs.
I do not know how good the boeings, with or without mods are working, but there is no problem with the a32nx. Try this again, best with developer or erperimental version

1 Like

I’ll keep trying with the A320 and B747 with some of the suggestions above. I won’t go 3rd Party aircraft just yet. I want to see if I can separate pilot error from aircraft sim error on the stock planes. I’m trying to believe that something so fundamental isn’t broken a year after release. Maybe I’m too idealistic (or stubborn).

You have to check the ILS frequency in the FMC!
Since a few updates ago the automatically entered ILS frequency isn’t always the correct one.

You need to enable the navaids in the map filter to be able to see the ILS (or more correctly localizer) frequency.

The FMA indications on the A320 PFD confirm that there’s a lot wrong with your basic A320 setup.
I’d stick with the more conventional and user friendly Boeing philosophy of aircraft ops…the 747 or 787.

1 Like

Since a few updates ago? I’ve been getting wrong ILS frequency from time to time in the default A320 since launch… :rofl: I had to always double check the frequency with the charts.

Do you know, that a real A320 set the departure runway ILS for takeoff first, if available? Later enroute it switch automatically to the arrival ILS, set in the FMS.
Don’t know if the default A320 is doing this as well, but the FBW does.

Right on the money for me.

Double check your ILS freq for KORD28C is 108.950 (I-VZE)

As others have mentioned, your plane is not configured for ILS28C. Zooming in to your CDU, you have 28L dialed in.


1 Like

But you need to correct this in the FMS on your plane. More than likely, it has nonsense. Who knows where its guiding you.

Before you reach VOGLR (to avoid AP turnaround bug) on the CDU, click KORD28L> Arrival > 28C> No STAR, VOGLR> Insert.

Then RAD NAV and ensure 108.950 is in the LS (Landing System) field.

Then you need to click LS (next to FD) on the “autopilot panel”.

Only once you are within ILS radio frequency reception range, then you should click AP APCH mode. You know you are in reception range if your landing system activates. You will get identifier (I-VZE), Frequency (108.950) and DME distance to target in the bottom left of the PFD. When the Localizer comes alive, you will get horizontal tracking diamond. When the Glideslope comes in, you will get vertical information as well.

Make sure your tray tables are closed and your seats are in the full upright position. NOW, enjoy your landing on KORD28C.

*above pics taken from internet.


Yeap, I know… I don’t have any issue with FBW now as it does the departure ILS frequency and arrival frequency automatically. I’m just recalling my experience with the default A320 during launch, back when the FBW wasn’t even a thing at the time.

1 Like

I just made a testride vom Midfield to O’hare 28C with the FBW DEV and it worked out. Little windy in windy city and the AP flown a little above glidepath but thats ok for me. :grin:
So i would still suggest, it’s a pilots error so far.

Yes it is! Gusts are back!

I think they’re there in real world weather and they’re built in the sim, but there is no proper configuration to set up gusts for your own custom scenario. (Hence the UI work needed in the release notes?)

1 Like

I’ve been saying this since the communication that they were reactivated.

1 Like

The AP doesn’t significantly deviate from the GS due to wind/turbulence IRL.

It’s “pilot error” in the third screenshot because the FD is basically useless since day one.
You are above the GS and FD shows a fly up indication!