Can’t even open game anymore

I’m assuming since the latest update (I haven’t played for a while) I can’t open the flight sim at all, it redirects me to the Microsoft store to update “Microsoft gaming services” which I did, but still can’t open the game. I’ve restarted and tried opening the game again and it redirects me to this update for gaming service. Which it says “this product is installed”
Anyone have any idea what’s going on? I’ve never had to update through the Microsoft store like this before, it’s normally within the game.

I had the same issue, solution:

1 Like

Thanks for the help but still no change. Why do i have to go through ■■■■ like this every time they update the stupid program. Seriously doing my head in!!

Edit: turns out a windows update fixed it. Ugh. What a dumb asssss

I got the same problem now but after installing the newest Windows Update…

In my case, the Windows update led to a cascade of downloads and more updates:

  1. Gaming Services wanted me to update and created an error. That led to

  2. Complete reinstall of Windows 10 and

  3. reinstall of 71 Gb of MSFS 2020

What a NIGHTMARE!

So far I have spent 5 hours with no end in sight.

This is stupid, I spent a fortune on a new PC, as well as for the game and the add on’s, and now it wont even start up! Has anyone resolved the issues with the Windows 10 update from yesterday? as this seems to point to that being the reason.

The same here. Microsoft Store says it hase some updates regarding Game Services, but gives error with code: 0x80070002. Windows update did not help.

I have the same problem when starting the sim. It takes me to MS store to download Gaming services.
I’ve tried to take ownership of both gaming services files to delete them but it will only delete one. I’m locked out! I guess I’ll try a clean install of windows.
I had this issue the day before the windows update and it did not fix anything.

SOLUTION

@PHL188’s method did not solved the problem for me, but here is another solution that made it:

How to Clear and Reset Microsoft Store Cache in Windows 10

OMFG, just reinstall

Same here. i try to load the sim and it just redirects me to the MS Store. I cant even see the sim in the program files on my PC so i can even see a way to uninstall it.

Default location

c:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.16.2.0_x64__8wekyb3d8bbwe\

WindowsApps is hidden folder.

Symptoms
When you try to install or start an Xbox Game Pass game on your Windows 10 device, you may be redirected to the Microsoft Store page for Gaming Services. Additionally, you receive error 0x80073D26 or 0x8007139F:

Resolution
To resolve this issue, install June 11, 2021—KB5004476 (OS Builds 19041.1055, 19042.1055, and 19043.1055) Out-of-band.

Run windows update and click “check for updates”.

image

Restart your computer when you install KB5004476 update.

I managed to update game services after deleting two registry entries, but now cannot see any other players even everything is set up correctly for multi player …I even logged in with a friend on same server same airport same time of day…his aircraft was invisible even though when I checked my friends list in MSFS he was showing as online and his location… Anyone has the same problem after updating game services?

I have the same issue precisely and had filed Zendesk tickets 108312 and 108229.

I had this and managed to get it working by doing a repair on the game service and the msfs app.Go to apps and programmes ,find them and click on the options,there you can do a repair.Worked for me.
Just to add ,you should click open advanced options under those apps,gaming service and msfs .Then click repair.Hope this helps.