Can’t launch msfs2020

I can’t launch msfs2020. Is it a general failure or it’s happening just to me? After clicking the msfs icon it appears briefly in Task Manager and few seconds later disappears with no message. Help would be appreciated. Thx.

everything Ok, here. Sorry budy. :no_mouth:

You can try doing a repair.If that is doing nothing try reset.Still nothing after that, uninstall the Sim ,then reinstall again.Maybe before you try those steps ,just reboot your computer and then try starting MSFS.Hope this helps you get flying again.

Thanks. I did all the stuff you advised me to do…uninstall, install, reboot it a lot of times…same result…thanks anyway for your advise.

I had to reinstall Windows 10 this morning and upon installing MSFS, I am getting the same issue - will not even show up in task manager :frowning:

AHH!!! Just remembered - I had to set Time to Eastern USA-Canada. Running OK now.

I just solved the issue.
search and type “msconfig” and stop the “Nahimic” servics.
Then restart your PC and MS2020
Hope that helps.

Topic moved into #bugs-and-issues:performance for issues launching MSFS.