Can‘t purchase anything from Marketplace

MS Flightsim Shop can‘t buy!

Hello!
I just wanted to buy an Airport on MS-Flightsim but it says:

Something went wrong, we don’t know what happened! Try again later.
But I can order and shop normally in the XBox Shop.
I’m in Germany!
Best regards

2 Likes

This checklist may be of some help:

1 Like

Thank you, but on XBox you can’t turn the online functionality off. It’s greyed out and is always on.
My status is offline on the Flightsim profile but i‘am always online on the XBox profile, that’s weird! How do i sign in?
I can see the marketplace and all the Discounts and Planes.

Ok, i‘am online now but the problem persists.
What a pity….

I had that problem last year it appeared to be caused by the payment method I was attempting to use and was fixed by changing the method of payment. This may have nothing to do with your problem I just mention it as a possible reason for it.

I’ve got the same error!

It’s dropping Error even not load the card select screen! So that’s trouble definitly not on a player’s side
Playing Xbox Series X|S, Kazakhstan

Also tried change Xbox (yes I’ve got one Series S and one Series X).
Tried VPN.
Tried to change region on consoles.
Tried to change accounts!!!
Nothing helped.

Wrote to Xbox support, they say they’ll look into it…

It’s the option in the sim, in the General options, under Data.

Usually yes, it is.
But this is completely different story. Because the error appearing instantly, so you can’t even see the screen where to pick a card and etc.

Hi folks,

If you’re having problems with the Marketplace, please submit a help ticket using the link below and one of our support agents will assist you. Choose the “Purchase issues” option from the dropdown menu.

Thanks,
MSFS Team

https://flightsimulator.zendesk.com/hc/en-us/requests/new

1 Like

I get exactly the same error message. Thanks for posting in the forum!
I don’t have it in Settings/Data-> Offline, as this area is greyed out and cannot be set.

Today the problem has been solved seems to be a server issues.

2 Likes

Hello all, newbie here!

I am having the above problem on both mine and my sons accounts, on 2 different Xbox Series X consoles.

I contacted MSFS Devs, they passed the buck to Microsoft, and microsoft recon its a MSFS issue.

Has anyone had any luck getting this issue resolved please?

The Marketplace is having some troubles, staff is currently investigating it.

Having said that, a wait is not uncommon.

Same problem appearing once again right now.
Any updates on that?