Cannot sync to cloud and insert game disc

Starting the sim it says my data cannot be synced with the cloud. If I choose to play offline it tells me to insert the Microsoft Flight Simulator Game Disc. The only choice then is to quit the sim.

I’m on the store version. This is happening since 4 hours now. Anything I can do?

Check if you are logged in to your MS-(xbox)-account. Check in the xbox-App on your PC.

Thank you, I was not logged in.

The cloud syncing issue persits, but the insert disc issue is gone and the sim started. Anything I can do about the cloud syncing?

Well, actually it thinks it’s my first start of the sim, it wants to adjust all settings, including graphics settings and settings for my peripheral hardware.

That would be catastrophic if it losses my settings.

Here’s what I see after starting the sim. I never saw this since I bought the sim in 2020.

Did you reboot the PC after this happened?

No, I did not. So I rebooted right now. The cloud sync message is gone, but the sim still wants to do a complete initial setup.

What can I do to get my setups back? I have 10 USB hardware devices and many different setups saved.

I don’t like to be the bearer of bad news, but if the reboot didn’t restore the settings, they may be gone.
This has happened to me as well, and it isn’t fun.

This is something you could try, I haven’t tried it myself, but it may work.
In the sim folder structure, find the SystemAppData folder and copy the wgs folder in there somewhere safe.
That contains your settings.
Reinstall the sim. If it doesn’t ask you if you want to use your old settings, or doesn’t restore them, continue the setup using the default.
After the installation has finished, shut down the sim and put that wgs copy back in, replacing the new one.
Start the sim.
If the sim notices a difference between the cloud and the sim it should ask you which you one want.
No guarantees, but it may work.

1 Like

Thank you.

Actually I happen to have a backup of the wgs folder (one month old, so reasonably new). I will try to restore the folder and see what the sim thinks about it.

1 Like

It was not possible to get my settings back.

1 Like

I had the same problem ones and i had to resign in to the microsoft or windows account. And i had to sign out the ms store, reboot, restart and update all was somewhere in the mfsf troubleshooting.

That is absolutely brutal. Asobo should add an option to manually save and load sim and controller settings.

1 Like

I think the problem was that I agreed to “fly offline” when asked by the sim. From there it did a new setup. Not only my profiles were gone, everything else was on default as well.

Anyway, I’m already working on redoing my assignments. I also use FSUIPC and will work towards doing everything in there. My goal is to not be dependent on the insim profiles anymore.


I am getting this same problem every week now. It starts by randomly getting Insert Game Disc. I close down the sim, relog Xbox, start the sim, and it runs first start setup. All settings gone, poof. This is ■■■■■■■■, and needs to be seriously looked at.

I have the the same, first happend about a month ago, and it doesn’t go away.

For some reason, the xbox app isn’t saving my login info, and I have to relog every time I want to start MSFS, else I get the “could not sync to cloud” or “please insert disk” messages.

I’ve had MSFS since 2020 (store edition) and I had never experienced this before.

This article may help.

Thank you, I had read that article, infact I had it bookmarked for future reference.

Unfortunately, none of those suggestions helped (and trust me I’ve tried them all) :sweat_smile:.

Funny because I’ve ran the sim for almost four years without any problems and only recently it started doing that. The quickest way for me to launch MSFS is to go into the xbox app (and sure enough I find that I’m not logged in anymore), and access my account again.

Not a big deal, but the article says “This issue is caused by Gaming Services and Microsoft is currently investigating it” and it’s dated 2022, so I was hoping a definitive solution might have been found.

1 Like

Not quite - the article was posted on April 22nd. :wink:
But you are correct in that, AFAIK, no solution has been reported by the Gaming Services team.

Duh :flushed:

On the bright side of things, without me doing anything, yesterday and today the xbox app has decided to recognize my login again :tada: