Can't download premium deluxe aircraft

I’m having problems Installing 8 of the 10 premium deluxe aircraft, I’m trying to download them through the content manager, once they have downloaded it says there is another update available but I can’t download it. I then restart the sim and go back into the content manager to see that they have reset and need to download from the beginning again. I don’t know what could have caused it.
I was playing the sim with all the planes installed on the 4-5th of February and then the next day, 8 of the planes were gone.
I don’t have any addons in the community folder.

things that I’ve tried to fix it but didn’t work:
1.log in and out of Microsoft store
2.log in and out of Xbox
3.log in and out in-game
4.restart the sim with administrator with Xbox
7.restart pc

the only other thing I can think of is to reinstall windows or reinstall the sim.
also wondering if bad internet has anything to do with it.


Have you looked here?

“Only 2 aircraft in the hangar” - How to install additional content? (First installation or reinstallation) – Microsoft Flight Simulator Support (

I just read through it but I’ve already tried all of those things and it still doesn’t work.

Have you looked to see if the aircraft were in your Packages-Official-OneStore file? If they are there, remove them and restart MSFS and download again from the content manager.

I’ve tried that as well

Hi @loganEB9256!
Let’s try it this way:

Go to the Marketplace in MSFS and click on “Full Catalog” then “Bundle”. There should be 3 listed as “Owned” if you bought the Premium Deluxe Upgrade:

  1. Deluxe Upgrade
  2. Premium Upgrade
  3. Premium Deluxe Upgrade

Make sure all those are showing installed. If not, install them.

This may/may not work since you have already tried installing some via the Content Manager.

Let me know!

I’ve tried installing premium deluxe again through the marketplace and when it finishes installing it says that they have been installed in the notifications but when I go into the hanger they are not. I restarted the sim and it said I needed to download it again, it’s basically a loop. Also the aircraft files are in the official mfs folder

What are the 8 aircraft that won’t install?

3.152 areobat
5.Baron g58
7.cessna citation longitude
8.virus SW121

OK - On the aircraft list.

Don’t do this.
In 2 days there will be an update to MSFS. Let’s wait until that to see if this may help push that content.

There have been cases where this has fixed that and/or a removal of some aircraft from the Content Manger and reinstall from there (without having to reinstall MSFS).

I have a meeting here, so I will need to get back to you later.

Ok I will wait until the update and see how things go from there,
found a video of the issue I’m having

Video says at the end, fs-base-propdefs is missing
Can you double check?
Maybe redownload also this package and retry the Cessna download?

I’ve done some research and apparently it shows up when there’s an upcoming update,
I think the best bet is to wait until the update and if it doesn’t fix it I will redownload the sim.
I’ve tried redownloading the premium deluxe package and the Cessna 172 multiple times.

Have same issue, with Premim Deluxe, Deluxe content downloading, installing but keeps showing up as not installed. Restart sim, can download again same thing. I have reinstalled from scratch all goes well except the Deluxe/Premium ccontent. It shows under the OneStore folder but not in the sim. Not sure if there’s a database file not updating correctly or a registry.

the update didn’t make the planes work again

Delete official and community folders and re install the sim.

OK so I reinstalled the sim but now the Sr22, longitude and the 172 skyhawk aren’t showing up I’ve gone to the content manager but they are doing same thing as before. I don’t want to reinstall the sim again as it takes 3 days

Once again they are in the files and they are downloaded but they are not showing up and saying they need an update but after you update it, it resets

OK. But it has improved, before there were 8 missing now only 2. Keep trying in the content maneger, I had this problem with the C172 too,
the sim solved the problem itself.