Can't Install MSFS2020

I started the download last night after restoring my computer to factory settings. Well, I woke up this morning to find it still downloading and it barley moved anywhere. Well, I tried restarting the game and it still says I need the 91GiB download. So, I hit update. Well after I hit “update”, it instantly says “continue” and nothing downloads. I hit this continue button and it goes to a black screen for about 10 minutes then goes to the screen with the volcano in the background, the blue bar moves very very slowly. Eventually, it gets about 3/4 done and freezes forever. I have tried everything from restarting my computer, to restarting the game (about 10 times now) and even tried uninstalling the game but I couldn’t. I ran as administrator all to no avail. Please help!!! I run a YouTube channel and I can’t stream or upload any videos about the simulator!

Try this from the knowledge base, it’s helped some people.
How to Reset the Microsoft Store App in Windows 10

  1. Open Settings.
  2. Go to Apps -> Apps & features.
  3. On the right side, look for Microsoft Store and click it.
  4. The advanced options link will appear. Click it.
  5. On the next page, click on the Reset button to reset Microsoft Store to default settings.

Didn’t work

Hope someone can find something else to help.

1 Like

Hi there,

Have you checked this article yet?

Well the thing is, I don’t get stuck on download files. It literally downloads nothing at all. Thats what I’m saying, it says “update” to download the 91GiB but then says “continue” without downloading anything


How about this article?

I would also send in a support ticket to Zendesk to try and have this resolved if you’re not able to find a viable solution.

I have sent in a Zendesk, but no response yet for a day already… :frowning: Also, I already tried everything in this article.