Can't see friends online

Hello all.
i hope this is the right place where to post my issue.
I never see my friends online, while they see me online, and can see me in-world, while i don’t see them.
I tried to search on google and around, but i did not find anything speaking about it.

Is there something i have to do in my microsoft account?
I always start a game with “All players” and meteo “Live settings”, so i should see my friends, but the most weird thing is that when i press ESC and use the top game menu, i always see them offline… grrr… i am playing on PC and bought the game on steam.

5 Likes

yep, it’s a huge issue and almost every time I post about it my info is deleted saying “Flagged by community” which I refuse to believe
Ive been through literally hundreds of attempted workarounds

2 Likes

Same for me - friends can see and even invite me to a party but that does not last for more than a couple of minutes. Best way is to just meet at the same airport with Live Players or All Players selected. Hopefully tomorrows patch will fix this🙂

i just sign out of xbox companion and download a new version for win10 and it’s working at the moment.
Unbelievable the companion app told me nothing of the available update

what do you mean as “download a new version of windows 10”? maybe this could be helpful if explained step by step, and working.

1 Like

I just have the same issue with a friend. I see him and every other multiplayer, we are on the same servers, but he doesn´t see me… Also group invitation is buggy then (we can both accept, but nothing happens)

yeah i would like them to fix this. My brother can see me on the world map but as soon as he loads the world, he doesnt see me nor i see him, except sometimes we meet up, but it’s totally random. for example tonight it doesnt work, but yesterday we could fly together.

i said “for” not “of”
The xbox app

alright, sorry, my bad. Unfortunately i got it on steam so my Xbox Companion doesn’t see any installed game… =(

So lame that there’s this bad issue.

I can see others and I’m online but can’t see my self in friends group. Also, if I invite a friend, an invitation goes out and the other person sees it but it disappears so fast they can’t accept the invitation.

Same issues here, this only occurred after the update. I haven’t been on the game for a few weeks so not sure when that update happened. It was about 7.5GB

Possible clue to not seeing friends online. After the update, the servers under my screen name show preposterous ping times. I’m going to see if I can upload an image of it here, perhaps programmers or tech support can learn something from it. My friends can see each other, they just can’t see me, even if I create the group and we all join it.

image

1 Like

Yes I see this too - no idea why

Hey guys. I added a secondary hard disk, and moved steam folders to it with steam. This caused a reinstall of the game. It is now fixed. Maybe a reinstall fixes? Dunno… Or changing stram folder… Or a different disk than the OS one?

I’m having this issue as well. I tried port forwarding bot the MSFS 2020 recommended ports and the Steam recommended ports. I even tried going DMZ on my router as a test. I can see one friend but he can not see me.

Anyone else have any updates or workarounds?

Same issue. Sometimes I know they’re online, we meet at the same airport, I can see them, but the drop down doesn’t show them online. Sometimes it works and I can see friends and they can see me, but lately only they can see me and I cant see them. We are on the same server, have All Players selected, and I can see them online in the drop down menu, I just cant see them in the sim. :cry:

Topic has been moved to #bugs-and-issues:online-services