Can't spin globe on opening Globe screen

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Have you disabled/removed all your mods and addons? If the issue still occurs with no mods and add-ons, please continue to report your issue. If not, please move this post to the Community Support section.

I don’t have any mods or add-ons.

Brief description of the issue:

I can’t click and hold with the mouse the globe on the opening screen when I want to find an airport somewhere in the world by using the globe. I can zoom in and zoom out but it’s very difficult to find a particular place that way.

Provide Screenshot(s)/video(s) of the issue encountered:

The screenshot would just show the globe screen - with the globe frozen in place.

Detailed steps to reproduce the issue encountered:

Open Microsoft Flight Simulator 2020 and click into the globe screen. Then try to turn the globe by clicking on it.

PC specs and/or peripheral set up if relevant:

Aurora Allienware R8. 32 MBs RAM, NVIDIA GeForce RTX 2080 Ti

Build Version # when you first started experiencing this issue:

This started happening many, many builds ago. Probably 8-12 months ago was the first time I noticed it.

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Check out this post, hope it can help:

Moved to User Support Hub User Interface & Activities to get community support and try to replicate.


Wow! Thank you so much! I’ll give that a try.

Thing I don’t understand though is it always worked up until a certain update and then it suddenly stopped. I didn’t change any bindings at that time (because I didn’t even know you could until now)!

Anyway, I really appreciate your fast reply.

1 Like

Yep, that worked! For some reason I had a customized mouse setting that didn’t have the “grab” thing on it. I switched it to Default and then the Grab thing appeared. So it all works now. THANKS AGAIN!

1 Like

Great to hear !, happy flights :slight_smile:

1 Like

Weird thing though, now that I think about it, is why is this even an option!? Wouldn’t the ability to grab and move the globe just be a default thing that couldn’t be changed? So strange that this can even be changed.

Just thinking… (too much no doubt)!