Can't start FS2020 - Error code 0x80004005

I can’t start MSFS this morning. Immediately after "Checking for updates"in the title screen, I get this message pop up:

image

I’m still getting it after a Windows restart, and signing in and out of XBox app.

I’m on PC. I’m in the SU12 beta, but this has not been a problem so far. I installed the World Update last night, and it ran alright straight after the update (not restarting the sim), but this error came up the first time I ran the sim from scratch.

There isn’t a reference to in error code 0x80004005 in the forum, so I’m not sure how to solve it. Suggestions would be appreciated.

1 Like

Click “start” > settings > time and language > sync now

Launch msfs as administrator.

Thanks for the suggestion. I tried it, but no luck unfortunately.

However, I will add it to my list of “things to try” for the future.

Open xbox app - sign out // microspft store app - sign out
Restart PC.

Xbox app - sign in // ms store app - sign in.
Update apps via ms store app.
Update OS via windows update.

Launch msfs.

Thanks again, but again unfortunately no luck.

I’m beginning to suspect a problem during the NZ World Update installation has caused a corrupted file.

:frowning_face:

I think it’s back to X-Plane till I get it sorted.

Maybe this will help you: 0x80004005

Moved to #community-support:tech-support which is more appropriate :+1:

Well, for some reason the problem went away.

Despite everything I tried, I couldn’t get more than five seconds into the sim. After one last attempt (which failed), I put the computer into sleep mode and left it to do more productive things for a few hours.

When I came back to it, I clicked on the icon without any real hope that it would be any different, but the sim loaded up perfectly normally. And has been OK since.

I can only assume there was something screwed up at Microsoft’s end (in the authentication or whatever) and that it sorted itself out. It doesn’t seem to have been anything I did. MS have made the whole thing over-complicated in their efforts to ensure they don’t suffer from piracy. In the end it’s the authentic consumer who suffers.

1 Like

I am sharing my recent experienced with Error code 0x80004005 in hopes it may be of some assistance to the next person who gets it. I recently purchased a new computer and installed MSFS from scratch. Everything worked fine until a couple of days later when I decided to clean up my work area. In doing so, I had to temporarily relocate my PC and network hub/switch to do the clean up. When I reconnected it all I must have reconnected my Ethernet cable to a different port on the switch which (I believe) resulted in the error message appearing. Not realizing this, I searched hi and low for a solution and found nothing that seemed to work for me. Somehow I accidentally deleted or uninstalled the xbox gaming service and in doing so, had to re-install it…this eliminated the error to my great relief. Today, I received a Cat 6 cable I ordered and thinking nothing of it, replaced the old cable with the new one and simply inserted it in a free port (other than the one I had been using for my PC). Low and behold, Error code 0x80004005 returned when I launched the game. As I had done no other changes to my PC setup other than disconnecting and re-connecting it to the hub, I proceeded to re-connect it to the same port I had previously connected it to and bob’s your uncle, MSFS launched without error. I can’t explain why MSFS wants to use the same physical port on my switch (perhaps it has something to do with Windows Defender or my anti-virus Bitdefender). I’m just glad I discovered this.

1 Like

Thanks for that description of how you managed to solve it. It’s something I never tried, but perhaps my system eventually restored itself to the previous settings automatically.

It’s certainly something I’ll bear in mind, and give it a try the next time it happens to me.