Carenado planes cause crash to desktop if using DX12

Can anyone else confirm wether they are having problems with the Carenado planes (M20 Mooney Ovation for me).
Works ok in DX11 but crashes to desktop if I try using the DX12 option.


I see the same behaviour. I updated PMS50 GPS mod, just in case, but still crashes in DX12 (tested with Arrow III). I also cleared SimObjects folder (inside \AppData\Local\Packages…) and let it regenerate on game start, as now the planes are classified into a new “Airplanes” subfolder, but still no luck.


Thanks for reply, useful to know it’s not just me as I was reinstalling the Carenado Mooney when I had a power cut. Seemed to resume the install once power was back but wasn’t sure if it was DX12 or a corrupt install that was causing the issues.

Better stay in DX11 for now, as DX12 is only beta at the moment. Using DX12 will break the FBW A32NX too, and who knows which other systems.

Yes I have the Carenado M20, PA44 and CT182T from within the market store and all of them CTD when using Dx12 - was hoping for an fix from either MS or Carenado as Dx12 is fine on my system, until then Dx11 it is.

Is this issue with DX12 and Carenado fixed yet?

I tried it after the recent mooney and SU8 update and it worked OK.

But as there was no change in the DX 12 implementation in SU8 I was still suffering from poor performance with DX12 so went back to DX11