Carenado Tablet on Xbox

After the latest update, I’m no longer able to open the tablet on the c170 and the Waco.
I am running the simulator on Xbox Series X

Does anybody know if there’s a workaround or how it is supposed to work right now?

I hope these updates won’t fix one thing and break another, and that Carenado maintains the excellent level of quality of their products

1 Like

From another post seems to only affect certain liveries. Try a different one and open a case with Carenado.

Are you sure. It has changed locations now. Animated pop up from a RH side door pocket. It’s not enabled from the yoke any more.
If you are trying to get it from the side pocket (on the RHS of each aircraft) and it still won’t open, then as stated in the previous post there seems to be certain liveries it works with and not others. try with default livery first.
Note: I don’t have the C170 but have 4 other Carenado aircraft that all have the tablet enabled the same way so am assuming C170 is the same.

I’m saying switch your liveries (the paint scheme / Color). Each plane comes with 4.

Apparently it’s working on 2 of them but not the other 2.

I have the 182T and it works fine from the side pocket on the livery I’m using but others have reported issues with the other ones.

Just tried it out on Waco and it’s fine (Note: this is on PC not XBox). Again stowed down by the RH passenger door as shown in the pic. Click on it and it should pop up.

Thanks, will try with different liveries combination.
As the Xbox users knows, there are a number of things that do not work on Xbox as they should, apparently because of the impossibility to have a proper test environment.

I will try a combination of aircraft/liveries and report back.

I tried every livery on the C170B & YMF5 and the tablet issue prevails on all of them on Xbox.

FYI, the day of the updates, I submitted a ticket for this and a few other issues at Carenado’s website.


does this issue effects also the carenado piper? I was considering it but don’t want anymore surprises (there are some piper videos i saw but they’re very old so not sure if it’s still working)

@NixonRedgrave did they get back to you?

We had a couple of email exchanges. They wanted me to photograph the versions I had installed of the C170B & YMF5, which I provided.

From there the only exchange was a thanks and they were sending it to their development team.

1 Like

It’s a minor issue I suppose and not an aircraft-breaking one, but I really can’t believe they’ve not sorted this. still. It makes me think twice about buying their stuff. I own the Waco, the C170, and the Arrow. The tablet does not work, on all three, in every livery. I’m sure it’s been drawn to their attention but as I say, they’ve still not sorted it. It does make me think they are either very slow or very reluctant to deal with feedback from their customers. I’ll probably not be purchasing their aircraft in future.

1 Like

carenado is always pretty slow with updates.

1 Like

They need to sort that out. It’s an indication that after sales service doesn’t really appeal to them, which isn’t a particularly good look.

same, did bought a couple but even if pretty and pleasant to fly they lack in depth and the tablet issue (which is more “breaking” on some theyr planes than others) is taking way too long

after seeing what the just flight pipers are in comparison to the carenado I guess I’m done, I’ll be waiting patiently

1 Like

It is possible that they (Carenado) have a longer update cycle but one thing that also impedes the end users of their products in getting updates is the fact that they are exclusive to the Marketplace.

Even if Carenado releases an update, it has to go through the Marketplace process before ultimately becoming available versus other developers where you can get it same day from their website.

Not saying this is the cause of the slowness / delay but it does exasperate the issue.