Cessna Citation Longitude Cant Scroll Approach List

Hello all. I was flying the Cessna Citation Longitude. I was given a landing procedure by ATC. I clicked the PROC button on the Garmin.

Then I click the Approach button.

Then I click Approach again to select the runway for landing.

image

Then a list of approaches is displayed with a scroll bar, which I circled in the image below.

image

I cannot grab the scroll bar in VR mode. I can grab it in non-VR mode, but I only want to fly in VR mode. Is anyone else having a tough time with this? If you have found a solution to this, would you mind sharing?

Thanks.

Use the Up and Down arrow buttons

Really, okay thanks. I never would have thought of that. I’ll give it a try. Thank you.

@meh1951, I don’t know why I did not think of this before. The up and down arrow keys move my seating position up and down in the cockpit. Are there other buttons that I am not seeing, or do you have your up and down arrow keys mapped differently than I do? Thanks for your help.

Just to be clear, I need to somehow scroll the list of approaches so that I can pick one further down in the list. I can do this when not in VR mode, but I would like to be able to also do it when I am in VR mode.

Try closing one eye. That works for me most of the time. I fly VR exclusively. Mainly the WT mods.

1 Like

If you don’t have this already get the WorkingTitle G3000

Release g3000-v0.7.2 · Working-Title-MSFS-Mods/fspackages · GitHub

Hope This Helps

I was having the same problem, closing one eye helped…try pressing right mouse button to get closer to the screen and you must aim very good to grab it

It seems the “click spot” to grab the scroll bar is very small

Well, I tried closing 1 eye (Left and Right) and I still can’t get it. I tried moving the mouse and dragging in all places along the left and right edge and the procedure buttons, and nothing works.

I will try the mods, but I am really frustrated that the developers cannot get this right with the built in Garmin. I know this has been said many times, but I wish they would take a break from improving scenery and focus on basic cockpit functionality.

We need all hands on deck focused on basic functionality!

You don’t have to use the scroll bar, right? There are up and down arrow buttons on the Garmin display, aren’t there? I could be mistaken, though. I’m obviously working from memory here since I’m not in the cockpit…

There are no up/down arrow buttons. I wish there were. That would make things easier.

Yea this is definitely a bug, since those up and down arrows are in different submenu, just not for the approach selection. They appear to the right side of back and home buttons

1 Like