Cessna Citation Longitute HYD and BRAKE fail

No matter if started step by step according to checklist or aircraft loaded in start position, my PFD constantly shows flickering HYD FW SHUTOFF and HYD PRESS warnings and (most probably caused by lack of HYD) a BRAKE FAIL. This is since AAU1.
Hydraulic pumps and PTCU are in normal position, of course.
Any hints?

are you flying with preset failures?

Check in the Worldmap → Aircraft → Failures

No, everything off.

check the switches in the right side of the middle cosole, just next to the throttle and the right MDF.

i see, you already checked them. give me a minute…

can you make a screen of your hydraulics synoptic pane in the MDF?

Don’t know about OP, but for me, these started after WU12, only way to get rid of them, is to restart both engines, then it stays away for some time.

If you are decending or climbing then it will constantly lose pressuare and the warning will popup, but on cruise or steady altitude, it stays away, last flight cruising 1,5 hours without problem, the second decent started, pressuare was lost.

And it loses the pressuare completly, on hydralics synoptic its 0 PSI, if you dont turn on the PTCU.

Also the bus open/closed logic button is not working anymore and it doesnt change automatically position while starting.

I’m having the same issue, and seeing the same thing on my hydraulics screen.

i will try to reproduce the failure.

meanwhile i recommend you to read the C700 manuals…


Thank you for the link to the Operator’s Guide. This will be quite helpful, I’m sure.

Full disclosure, I didn’t have much time yesterday morning and used Ctrl-E to start the engines. Perhaps this could be related.

Auto-start (Ctrl-E) is the issue. If you use the in-game engine startup checklist, you do not encounter this problem. I just confirmed this in a flight from Raleigh to the Outer Banks. Love that VNAV now works as it should!

Oh, that makes sense. I never use autostart. Starting the engines is with the C700 really simple and i enjoy it.

So firstly that in-game checklist is very outdated and incomplete when compared to that linked operators manual. Secondly it still gives the same error no matter if you start it with that or the operators manual procedure. I have used that manual procedure after AAU1 for like 25 hours without issues, now (after WU12, which makes no sense, since I have not spotted any notes for changes on C700) flying the same way theres this error.

And just to confirm I just did test fly and the error was still there. Started dark & cold, startup with checklist, takeoff and small climb. Total time until error like 10 mins, then there it was was again.

No matter wether I do autostart/CTRL-E or manually with checklist, I still get the HYD errors.

Ok… stupid question, which livery do you use?

There are some visual bugs with the spoilers by some liveries. Maybe here is a similar issue :thinking:

I haven’t launched the simulator in a few weeks. So when I did, I got WU12 and Release In the release notes, they listed several significant updates/changes to the Longitude and the G5000. Not sure if this update landed at the same time as WU12 or if it released before (and therefore unrelated to this problem).

Release Notes for Version

They did list the Hydraulics as an updated system: “Hydraulic system, including fluid-based pressures sim with realistic hydraulic accumulator behavior and system knock-on effects from hydraulically powered systems as well as full PTCU simulation”

Was flying the N804QS Netjets livery first time, after the error appeared, emptied community folder and all test after are with the stock livery and game, so no change there, still got the problem. When I’m home again can test if it’s just a visual error.

@fenster24 That release is the AAU1 if I’m not mistaken and it was released four weeks ago as those notes, while for me these problems started last week.

I’m not sure if there was some other smaller update and release notes close to WU12 that I have missed, but that is the update I noticed and downloaded when started the game and first fly after did get the error.

Ok, i‘m flying on the Xbox. I often fly long routes with the livery 01 C700 (red/white) for 3-4 hours. Never have problems and never use auto-start.

Do you have the issue on PC or Xbox?

And the hydraulics pump a/b buttons are on NORM? Really check them (switch to MIN and back to NORM).

Then the PCTU is on NORM? Switch it once to OFF/Hyd Gen and then back to NORM and try to start the engines again.

PC Steam version. I have flown about 150 hours without problems until this and all the switches are on, tested every trick in the book and of it for the C700 and still got the issue. Also it’s not visual bug, plane rolled of runway because there was no braking with the errors on.

But I was looking from wrong place. I had the rolling cache turned on, now I deleted the file and turned it off, there were no issues climbing to FL400 on quick test, need to do more testing when have time but seems that it was the problem, why it affects the planes behaviour I have no idea.

Definitely have tried everything in manual. Checked failure settings. Deleted cache file. Turned off cache. Reset. Watching the hydraulics screen its system B not holding pressure. It drops and rebuilds pressure. Green line between engine and brakes etc…flickers. Definitely affects the aircraft and operation. A fix for this is a must have to fly the Longitude in my humble opinion. Back to my Hondajet until a fix for this thing I guess. Disappointed, really wanted to fly the Longitude after the avionics update.

Think I’ve been able to find the cause and effect. When I zoom in to instruments I can make the flickering of the HYD message start. Zoom out and it goes away. Experimenting with graphics settings I turned VSync on and problem seems to have stayed away. Running 4k with DLSS.