Cessna Citation Longtitude Landing Gear not going up


I recently enjoy the Cessna Citation Longtitude since I upgraded to the Deluxe edition.

But there might be an issue. It feels like a bug.

Long story short, when Im in air, Im not able to pull the landing gear up. When I look outside the plane, its still down. When I look at my instruments, it is still down. The button/lever is up in the right direction.

Am I doing something wrong and does anybody else have the same issue?

Game is the MS store version. Running the game on W10 on a HP Omen 30L with a GTX3080

As a new user, Im allowed to add one image. So this is how my lever shows, but the instruments say “Gear DOWN” and outside the plane, the wheels are still out, like the were during take off.

Do you have any additional livery installed?
If yes, deleted anything Longitude related in your community folder.

1 Like

I dont have that, so cant be it Im afraid.

to clarify on the instruments:

Flight model is set to modern? No mods at all in the community folder?

1 Like

Yes, it is set to modern. Didnt know about this setting, but apparently its set to modern.

And no mods at all…

Not sure, but the gear might be locked at higher speeds on the Longitude.
Suggest to reduce the speed below 200kts and try again.

1 Like

I see two things with this picture and they are both related. You are showing a groundspeed of 429 kts.

One, I have no idea how you are going that fast with the increased drag of the gear being down.

Second, aircraft have a speed limit for gear operation. If you exceed that speed in a real aircraft a couple of things will happen. There may be a speed sensor that prevents you from operating the gear above the gear operating speed or the gear may not operate due to the force of the relative wind. You run the risk of damaging the gear if you exceed that speed.

Now, is any of that modeled in the sim? I have no idea, but try getting your gear up before you hit 200 kts and see what happens.

Interesting catch, and I tried it. Under 200kts it still does not work. But during this test I discovered some things.

First, when I do have the lever UP(and the wheels and instruments show it is still down), it apparently is actually up. How do I know? Well… with zero throttle, I do get that verbal warning “landing gear, landing gear, landing gear”. When I pull down the lever, and still keep throttle at zero, it stops the warning.

So, it does do something effectively with the gear, it just does not show on the instruments or the outside render of the plane.

Very strange. Does the gear up/down work with e.g. the TBM?

Yes, it does. Thats my other “go to” plane actually. Even the older Cessna jet works fine. Its just this model.

As a last resort you could try deleting the Longitude from within the content manager.
Exit MSFS, restart, and re-install it.

1 Like

Brilliant. We never know the rootcause specifically, but it works again. Gear is up and shows up. Thanks man.

1 Like

That’s great news. :+1:

1 Like

Sad news, the bug is back. It initially solved it, but now after couple times, its back… :frowning: