CH Pro pedals Brake Axis

I set Joystick L-Axis X to LEFT BRAKE AXIS, Jystick L-Axis Y to RIGHT Brake Axis. Everything seems OK on Control Screen, but in sensitivity screen when I gradually press brake it goes all the way up, and then down on the graph.
0 position of the brake is in 50% pedal deflection. Reversing axis doesn’t help.
So, too release brakes I have to hold 50% of pedal deflection. It is ultimately frustrating. How to fix it?

1 Like

go to youtube and search for Squirrel videos. He has #2 for setting up controls.

Try setting a small dead zone, maybe 5%. That should do the trick.

Just give it a try. I use CH ProPedals and in sensitivity it does the same thing. In the sim, the seem to behave just as you’d expect (and if you look at the line graph below the sensitivity graph, it does go from zero to max … at least on mine):

Something is out of wack for sure … but seems to work as expected.

I have tweaked the sensitivity a little, but everything set up pretty easily.

You might try getting the CH Control Manager and calibrating the Pro Pedals. There is a check box there for centered or not. The rudder is checked and the brakes not. If you do get the CH Control Manager then you have to uninstall the Pro Pedals, reboot and reinstall them again after CH Control Manager.

1 Like

It was all due to parking brake. Apparently kicking toe brakes doesn’t release parking brake here… Thanks for the help.

This is the same problem I have with the Saitek Pro Flight Combat Rudder Pedals.

0-50% of the physical pedal travel is 0-100% of the brake travel in the sim.
50-100% of the physical pedal travel is 100-0% of the brake travel in the sim.

It’s like its expecting the toe brakes to have a ‘central’ 50% point like a joystick axis.

If the sim had some more axis tuning options we might be able to tell it how to work properly.

EDIT: Ah, yes, if I release the parking brake, the pedals behave correctly, even though the ‘sensitivity’ options seem to display strange behaviour. Thanks @Horvath8311 :slight_smile:

Yeah … baffled a lot of us that one! At least it works.

kijk op youtube squirrel tutorial 2 oplossing voor alles!

This is still happening here to me.
In XPlane the axis works fine so its no a joystick error.
It’s a bug in MSFS that in MSFS ONLY, the is staying “centered at 50% when it should be a 0% to 100% slider”.

What is the way to fix this?

strangely only MSFS needs this solution on my Win 10 computer, all other games are fine, but for MSFS one must calibrate it with CH Control Manager