CH pro pedals

so I got a CH flight sim yoke and pedals yesterday.

Never had pedals and I normally fly the CRJ700…

when I press the brake it works but seems that it starts decreasing the speed till it stops and even if I press a little and increase than throttle it still continues decreasing the speed till it stops and to start again need to switch on and off the parking break.

am I missing any setting or it does work like this ?

On the yoke I have toggle parking break on button 6 and on the pedals have the right and left break axis on joystick-L-axis y and joystick-L-axis x

Hi @Godwisper,
Have you seen this post here? This member was kind enough to post images of the bindings and helped me when I was setting mine up:

1 Like

I have the CH Pro Pedals,

To get them to work properly I had to calibrate them within Windows first. Click on start and then type “Setup USB Game Controllers”

Once in there, you will see your devices, select the pedals and then click “Poperties”. Once in there, select “Advanced” and then “Calibrate”.

Once completed, I then confiugred in MSFS without further issues.

Hope this helps.


yes I did see that. Am almost like that but not using the mixture and propellor axis since I fly the CRJ700.

Moreover, I don`t know if I still need to set up the parking break in the yoke section while having the brakes on the pedals setup too. At the moment have both setup but when I press the pedals it starts decreasing the speed but continues to decrease till aircraft stops and not just decreasing a little bit the speed.

You might consider trying it first with the “normal” parking brake key combination CTRL+ Numpad DEL instead of using a button on the yoke. That’s the way mine is set up and it works great. If that works, then you can go back to the “button 8” assignment and see what happens.

1 Like

yes I did calibrate both in windows

since I am I sim in VR am trying to get rid of the keys

Parking brake and brakes are not the same thing.
You can have a toggle on/off for parking brakes on a button, it doesn’t matter.
But the brakes on pedals should be bound to the left and right brakes axes of the pedals and you also have to set sensitivity and curves for these axes in MSFS

1 Like

Here’s a screenshot of my setup incase it helps.

1 Like

Thanks although mine are set like that. Will try again

1 Like

Might want to uninstall them from device manager and reinstall them. That’s what I had to do when I first tried to use them and they were acting funny

Calibrating the brakes in Windows is a bit tricky. I had exactly the same issue until now, and I never found a working solution. Even cleaned the potentiometers, but that didn’t change a thing (it didn’t hurt of course). But now I think I found the issue: When calibrating in Windows, it first asks you to make circles with the controller, this you can do easily with the brakes. But in the next step, it ask to leave the controller in the middle position. And that’s the point I missed. If you don’t put the brakes to the “middle position”, you will have exactly the mentioned effect. But it’s very hard to assume a middle position with pedals. It’s easier, if you do it after running the circles, where you see the position of the cursor. Put it in the middle, then press continue in the window, and continue again without changing the position of the pedals. Done! Now it finally works!

If I remember, you have to reverse the brake action in settings. I have not had mine for a while and I may be wrong.