CH Throttle Quadrant idle detent is being represented as the halfway point (Solved)

I have a CH Throttle Quadrant. The idle detent is being represented in MSFS2020 as the halfway point. You can see it with the in-game throttle graphic. I can not fix it in the sensitivity settings.

This error is especially evident during landings and is really weird since the prop and mix are correct.

Here’s the thing - I have filed this with Zendesk multiple times and each time “customer advocate” marks it “solved”.

Anyone else seeing this issue?

From another website

This is what I did to get it working:

Grab the drivers from Thrustmaster

Calibrate the throttles (Thrustmaster has a video on this)

Calibrate the detents and zones in the EFB

Thrustmaster drivers? For a CH product?


This message must be at least ten characters

It was the MS default driver. Whenever you unplug/plug the CHTQ, the driver settings appear to reset. Anyways, re-calibrating fixes the detent issue.

Interesting that the driver treats the CHTQ as a joystick with four additional levers.

Along with no support for the old Force Feedback 2 joystick, it looks like MS wants us to buy all new peripherals. Rrrrright. :wink:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.