CH Throttle Quadrant issues

Hello All!

First: I like the new msfs2020! Having an real world star scape at night is amazing, at least. I see scorpio and the big dipper, great feature.

Second: i have some issues with my ch throttle quadrant.

It is like windows recognizes the throttle. For Win10 it is recognized as an three axis joystick with three rotation axes. So you have X/Y/Z Axis and X/Y/Z Rotation.

The problem is, that windows expect an centerpoint for the axes and that on axis X and Y the detent point at the throttle is recognized as the center. On all four other axes its no problem to set center somewhere else but on X and Y detend = center.

That causes that this axes jump from 0% to 50% around detent and that they are only adjustable between 50% and 100%.

Anybody with an idea to fix this issue?

Thank you.

1 Like

Just for the record: CH Products Throttle Quadrant works flawless in X-Plane 11, inclusive reverse thrust. It would be welcome to see the msfs2020 team have a look at this.

3 Likes

Ok, got it. It requires the calibration through the ch products control manager. Could be easier (see X-Plane) but works.

I think you may have solved my problem! The guys up on Avsim and Flightsim.com seemed to be conflicted about whether or not Control Manager was necessary. And in another thread up here, someone noted that the quad needed to be plugged into a USB 2.0 socket. I had that problem where I couldn’t calibrate the quad, so after initially removing the app, I re-installed it and plugged the quad into a USB 2.0 port.

Going there now to see if that worked…keeping my fingers crossed.

It will work! I have an very old ch throttle quadrant (2007) and it works now 100%.

I plugged it into an native 2.0 USB port on my mainboard, installed the ch control manager, restart, open the control manager and calibrate the throttle within the control manager.

Somewhere in this process I wasked to install a new device and accepted this.

After an restart the old entry for the throttle in the windows controllers list was gone and it was shifted from the first line in the controller list there to the last position.

Now all six axes and 24 “buttons” are working.

Hope you can fix your throttle too, it is not the hardware.

Much better of course would be an native support by FS2020 just like X-Plane does. It is just one of the stranger things with FS2020 that, allthough there are very few dedicatet flight controllers out there, the mighty mighty microsoft was unable to support this handful of hardware out of the box, especially when it goes to ch products. Both companies sit nearby and the controllers are on the market for decades. So, hey microsoft, have a coffee, move your butt a little, walk over the street, buy some ch hardware and xxx support it :slight_smile:

Thank you!

I still cannot get mine to work! I did move it from a USB 3 to a USB 2, and re-installed the Control Manager, calibrated it using that, and I can see the 6 axes now (though they still don’t work too well) but none of the switches, including the ones on the levers, can be seen by FS2020. I can see everything using Control Manager, but that\s about it.

U have also an older CH Quadrant Throttle from 2004, and i had to calibrate it too, and works after calibration perfectly with all but one plane (TBM930) with the feather position due the -z to +z range of the levers.
MSFS seem to work mostly with z to z+ or z to z- axis and vaguely remember having simulair issues with my Fanatec Pedals for racesims in some Sims, and to have to enable combined axis to funtion rightly.

Havent found that option in the CH Control manager, but i use SPAD.NEXT where i could reprogram the events the throttle levers make, into one that MSFS can use so the throttle in the TBM930 now works as well…

1 Like

I use my CH quadrant all the time works great with MSFS2020. Except reverse binding but that’s a MSFS issue not a controller. I don’t quite understand your issue. Did you install the CH Control Manager software? I only calibrate and setup using that…

I’ve got the CH Throttle Quadrant. Set it up in no time flat. One thing for me is that I personally learned through the years that Control Manager software they developed gave me far more headaches than it was worth. I haven’t missed it for years and that’s with using their yoke, Combatstick, peddles and quadrant in four different flight sim titles and have never missed it. I think one time I temporarily installed it to dial in the peddles once but that was it.

1 Like

The CH Control Manger has three modes.
Make sure the proper CH names show in Windows’ USB Game Controllers.

Responding to an old topic but I am finding that CH throttle quadrant buttons #20, 21 and 22 cannot be assigned to any action. While those buttons are detected during button assignment, they don’t get saved.

Could someone kindly confirm?
In my system, button 22 for example is engine 4 reverse thrust detent.

Many thanks!

@MikePapa4008 Yeah the mapping UI is currently busted in MSFS with the detents. It doesn’t seem to reliably detect them going back which should just register as a joy button press. But it doesn’t matter as there is no way currently to map the engine reverse to a button. (least not like in FSX)

Thanks for your response. The only way I have found is to assign reverse detent buttons to the respective engine’s “reduce thrust” shortcut. That activates reverse just fine.

@MikePapa4008 Did you map that with a joy button or keyboard? I’ll have to try that, I’ve only had luck with a keyboard mapped key and the built in key repeat rate.

You need to go to the controller assignments and under power management > throttle there are items called throttle 1 decrease, throttle 2 decrease etc.
To those actions you need to assign the button that corresponds to the correct engine lever at the reverse detent (full back). Then after touchdown you pull the levers back and engines go into reverse.

I still cannot get anything on the quad to work except for the 6 axes. None of the switches work, although they DO show up in FS. With a regular switch, when you program it, and then use it, it highlights on the list. When I program the quad switches, they show up in the list, but when I use them, nothing happens.

That’s the problem - FS sees them and shows them, but doesn’t register them. I’m using a USB 2 port and the CH Control Manager, so…