CH yoke and screen save

My CH yoke and pedals prevent my computer to turn on screensaver and/or my monitors to go to sleep. Only when i unplug the CH product, will my computer act as per power saving settings.
It is weird, because i only have this issue since a couple of weeks. (days maybe) and before that i could leave the CH yoke/pedals plugged in into the USB ports, but since recently (latest W10 update?) not anymore.
Point is… some setting will be able to fix that, but which one? Anyone??

Have just done a quick test, I have CH yoke (no pedals) and when plugged in my computer is able to go into sleep mode. I have the latest W10 update.

like i said… some stupid setting somewhere :confused:
Oh… and just to be clear, i’m NOT talking about computer sleep mode, but monitor sleep mode

My own gear doesn’t do this. Do you perhaps have a switch on one of those devices which is giving constant input. I’ll check tonight, but I don’t think moving my yoke, rudder pedals, or throttle will disable the screen saver.

SOLVED
it was GeForce Experience. Uninstalling it solved the problem.
also see this threat

1 Like

Indeed - mine are set to not do that either.

So it was the GE Overlay itself that caused the issue?

Apparently yes. After de-installing all worked fine again.
Not sure about NVIDIA Experience and its added value anyhow.
Same for NVIDIA Broadcast and Frameview +SDK either. These guys push a lot of software on you, but probably best to just stick to the drivers.