CJ4 Community Mod by Working Title Released

Yep, can’t figure it out!

anyone have problems with autopilot, not founding fligth plan and banking over 45º in an endless loop?? i dont experience this with the vanilla version

3 Likes

You guys are the best, the CJ4 is my go to plane now besides A320x :+1:t2:

1 Like

Once again many thanks for this new step in the right direction!
But I have two problems/questions about version 0.5.0:

  1. When I adjust the cabin lighting in the mod menu, the setting is not saved. So when I call up the menu again after quitting, the lighting is back to “off”.

  2. When I import my flight plan from Simbrief, I only get a “direct-to” flight plan, without waypoints (i.e. a straight line between my two destinations).

Am I doing something fundamentally wrong here? Or has anyone else noticed these things?

Side note: I have installed the current Nav data from Navigraph. Does this possibly prevent the simulator from importing the waypoints?

Thanks for your support!

@InacticeCorpse Thanks for the feedback

  1. Yeah that will be fixed in 0.5.1 we will release very soon
  2. There is a bug that parsing fails when you have departure procedure set. Remove that from the route and it should work.

The import will not set departures and arrivals as there are too many possible complications data wise. And the real world pilot route function would also not do it.

P.S: the latest thread is here https://forums.flightsimulator.com/t/working-title-cj4-v0-5-0-released-with-simbrief-fms-import

1 Like

Many thanks for this quick answer! Makes sense and I will give it a try next time :wink:

I must be doing something wrong.

  1. Downloaded zip file, unpacked and copied to my community folder
  2. Launch MSFS, can see the this update listed plus the base aircraft in the Content Manager
  3. Fly starting while running at the end of runway… PFD’s MFD’s and FMS screens all blank- avioinics switch on. Toggling switch, clicking buttons etc… nothing enables the screens
  4. Fly starting cold & dark at parking start with ctl-e, engines start avionics switch toggles on etc… PFD’s, MFD’s and FMS screens all blank.
  5. Remove folder from community, restart FS and repeat steps 3 and 4 and all the screens are enabled.

Its got to be something obvious that I’m missing that turns the displays on with the update… but I’ll be darned if I can find it.

Thank you so much for your work and help!

by “update”, I mean the mod…

Sounds to me like you are running an old version.
Go here Working Title CJ4 v0.5.1 RELEASED (with Simbrief FMS import)

Oh! I am such a goof! It was the wrong version! I had 0.2.0 downloaded by mistake. Thank you so much!

I installed v0.5.1 and tried it out for two flights. In one case, flying an instrument approach with ceiling below 1,000 ft, the autopilot was wandering above and below the ILS glideslope in approach mode. It seemed to be trying to follow the glideslope, but I wonder if either the Asobo modifications in the recent patch or the PID changes in the mod have tried to slow down the oscillations to such an extent that it wanders up and down a lot before correcting. Is anyone else seeing this behavior?

i just did a flight at EHAM with the CJ4, 27knt wind with gusts to 39, and it followed the glideslope perfectly (untill windshear happened). so no, not here

There are no autopilot PID changes in the mod

1 Like

Not sure if this belongs to here - as I expect this is a general problem, hoewever most obvious to me in CRJ4 with this great mod;
my problem: the FMS does not show any departure nor destination. It also does not show any legs, even the FP is loaded in the background.

  1. for me it’s not possible to enter the departure airport into the FMS… it “accepts” it i.e. the ICAO letters disappear (no error msg) but the FMS itself does not show the “origin”… same with destination.
  2. if I plan the route before start, the FMS is also empty…however it somehow seems to be loaded in the background as I can select FMS as source and the AP follows the legs with “NAV”… but the MFD is empty (no route showing) as well as the FMS itself.

Any help would be appreciated.
Hint (I hope it’s not the case); I installed the sim on another drive than C:\ and on another drive than my usual steam software…

Never heard of that yet. Are you on the latest 0.6.0 version?
This thread here is very old, of the first version.

Found bug on descent PFD freeze and drop speed to zero, then after 20-30 sec it back and show huge overspeed.

Try getting the latest version v0.6.0 if you don’t have it already.

Thanks @dga711 and @DabullAir - affirm, I am on 0.6.0 - and I have this problem since the first version; my MFD never showed anything and I never could enter my ORIGIN nor DESTINATION in the FMS… in the earlier version I even had an error message.
I also get an error message when I try to enter a waypoint; “Doubles Found”.
However, this is not only in the CRJ4 - this happens in all planes…

It was exactly with 0.6.0, never saw it with 0.5.1