Classic dial cockpit night lighting bug

I am currently using the Valve Index with Steam VR and OpenXR.
The experience is absolutely amazing and everything works great in my case.
I just noticed yesterday, going back to the classic Cessna 172 to test the new Steam VR World scale option, which by the way is amazing and completely changes my experience in VR for the better, that when flying at night and having the cockpit dial light turned on, there is a major render bug. The left and right eye render differently, creating a wide black flickering vertical band inside of each dial. The rest of the cockpit lighting is great. I have tested other plane with classic cockpit dials and the problem remains the same. I don’t know if this is something that appeared with the new SU4, just wanted to flag this new render bug I discovered with my setup.
Please vote if you’re experiencing the same render bug in VR,

The bug has been here for as long as I can remember. Never found any other information on it though, I would just avoid flying at night. I added a picture to show what the problem is.

Let me know if this isn’t actually the same problem.

Edit: I should probably clarify that I’m also using the Valve Index, this might be part of the problem.

Yes, that’s the problem, if we look at the classic dials from your picture, we can clearly see the black band right in the middle of them, and they also differ from LF to RT eye render.
I also have a Reverb G2 that I tested with MSFS2020 again after seeing your reply, and I can confirm that there are NO issue at night on classic dial cockpits renders.
I won’t go in why I switch from using my G2 to my old Valve Index for FS2020, or let’s just say it has to do with light house tracking and motion compensation with motion sim. I am anxiously waiting for my Vive Pro 2, I am curious to see if the headset will have that same problem.
I will open a zendesk ticket.
Thanks for your insight.

I’m experiencing the same on the Mooney (amongst others) but interestingly, the Turbo Arrow is fine until I download the improved lighting mod from .to and then it goes the same with the vertical banding that moves with the headset. This bug has there since VR arrived.

Same problem here on the Eagles using PSVR HMD and IVRY software, so it is working as a SteamVR native visor.
OpenXR active on SteamVR preferences.

Same issue! wish this thread would get more votes!

I’m having this issue as well. Searched all over and this is the only place I’ve seen it mentioned. I’d love to take some night flights in my Arrow III, but this bug makes it impossible.

Commenting only to get this to gain more traction. Same issue here with the Index. Makes flying at night a miserable experience.

Still a problem to this day.

1 Like

I too get this in some Steam gauge aircraft.

But a “work around” is to move one’s view closer to the dials. This stops the “Zfighting” effect.

I get this effect in other 3d app where I place a “face” or a plane to close to another plane or “face” and move the camera past a certain distance.

The renderer cant quite “decide” which plane to render in priority and causes the exact same effect.

This might not be the cause but the result is incredibly similar.

Can we edit aircraft models in Max etc?