Combined Microsoft Gaming Services + MS Store Issues


I am sure you will have allowed everything Xbox or Microsoft Flight-related through your Windows Defender Firewall.

yes, and as said before everrything was working fine at the beginning… did nice flights…

And as it is DELL I am presuming McAfee will be installed on the Laptop it could be blocking you?

no, no way to let this kind of … on my laptop :upside_down_face:

This is what I recognize. Then MS updated Windows to solve this issue. When I installed that update, the issue started with me. Whenever I tried to start MSFS it redirected me to the store. And in the store there was nothing to do. I solved it by resetting / repairing gaming services. I had to uninstall / reinstall it a week or so earlier to get the last update.

I think your reinstall might have come when MS was sorting all this out (and seriously, it’s a mess… this whole business with GamingServices / XBox and Windows mix… I think they’re still trying to figure it out themselves).

So by trying to fix it, you might by now have messed it up so badly that a Windows reinstall is the only way out. Without blaming you mind you. This is on MS and their messy store. I hope they improve this in Windows 11.

So basically I’m saying that a Windows reinstall this time might stick. Still not advocating it, but getting help from here will be near to impossible. I think no one from a distance can just diagnose this and fix it. It seems you already tried everything yourself anyway.


Unfortunately, the exact same thing happenned once, i reinstalled everything, and it came back… So I am a bit afraid to reinstall again from scratch and encounter same issues in 2 weeks !

I fully agree with you, the XBox/MS Store/MFS2020 thing is a real mess, just a way of getting issues for user (3 more chances in the end…).

Feel like a Beta tester on a realeased game, but with no support at all from editors. Not really cool.
But many thanks to the community…

checked, everything’s fine :frowning:
(at least for windows update, not for me)

I think if you do reinstall and it works, focus on GamingServices if you get into trouble again.

Either reset / repair (worked for me) or try to reinstall. But following the Windows Updates, this issue should be resolved. :crossed_fingers:

What about gaming services version?


When you get the chance, please consider updating your topic’s title. Your title should be short, simple, and should allow users to understand the purpose of your topic without opening it.

Good titles are important as they improve the chance others will find your topic when using the search system, and when browsing through the topic feed, and when users are seeking help on a similar issue.

You can change your topic title by clicking the pencil icon next to your topic title at the top of the thread.

According to the Code of Conduct, please do not create duplicate topics. Use existing topics so that issues and votes do not split.

Thank you.

why didnt you make a checkpoint after it ran well???

done now. But no topics mixed both issues…

Because I couldn’t imagine it would go wrong again…

Finaly reset my laptop once again… spent the end of sunday to do so.
Working fine now…
Hope this is the last time.

Reset my laptop once again finaly. Working now… hope this will last more than previous time.

1 Like

make a restore point when all works, so you can fallback way more easy and quick.

Good idea :wink:

System image backup is better in this case :wink: