Connecting Avare EFB to MSFS

The other sources I’ve found discussing how connect Avare to MSFS were rather lacking and missed some steps, So I wrote them up here.

  1. Follow the instructions on the web to download “xConn v05” and the “FSX Simconnect” programs. (search Google for Connect MSFS 2020 to Avare and you’ll find the links)

YOU DO NOT NEED THE AVARE I/O Plugin!!! It’s been built into the software for quite a while now.

You can download xconn here
You can download older simconnect for xconn here. Install all three versions in order. Follow the directions in the readme.

  1. I have Steam FSX on my computer and MSFS 2020. I just clicked on the three simconnect.msi programs to install them. I didn’t have to do anything, I don’t even know where they’re installed or how MSFS knows to communicate with them, especially since they are FSX variety Simconnect programs.

  2. I just put xConn v05.exe on my desktop for testing. Obviously you can put it anywhere. Started it.

  3. You’ll see it in the task menu in the bottom right corner. Right click it and select “Properties”

  4. Under Ouput, enter the IP address of your tablet, Port 49002, and use UDP Protocol

  5. Under NMEA I did not have “Use Aviation Data Format” selected, all the rest of the boxes are selected.

  6. Under Time, It’s set to “Use FSX UTC time”

  7. I left Satellites as default (1.0, 1.0, 1.0, 3D Fix)

  8. I started MSFS and went to my airport. In the bottom right I did see a window pop up and say it was communicating with xConn.

  9. In Avare, under Menu/Preferences/GPS/GPS Position Source, choose “Avare IO Module Only” (You don’t need that IO Module addon app anymore, it’s built into the software)

  10. in the same Preference menu location, Under “External WiFi Port”, enter 49002

Then it just worked for me.

If you don’t know, Avare is a full featured Android Electronic Flight Bag program that gives you access to the latest charts (Section, IFR, Airport Diagrams, approaches, etc) and chart supplements and weather for flight planning purposes (it has a W/B function as well, and you can even file a real flight plan if you’re a pilot directly through the software), and it acts as a moving map as well while you’re in flight. And it’s free. For all that. Check it out. It’s not as pretty as Foreflight, but, it’s still under development and it’s pretty ■■■■ good.

All the plates including the airport diagrams are georeferenced, so you can see where you are in reference to the plate when you’re taxiing or on approach or departure.

I’m no expert at the moment, but I’m getting there. Apparently instructions in the use of Avare are rather sparse as well (there are some instructional videos from 2017 I have yet to check out). I may do a video at later date. But don’t hold your breath :wink:

5 Likes

Thanks for the better detailed instructions!
Seems like people pretend to be coders these days and the less that must be written somehow means a better post, but it doesn’t and I can’t stand lacking information.

Also, I share your hatred of apple, haha. I own three of them but unfortunately I need them for other things like music, work, etc.

PS. Navigraph is almost the same you get with foreflight these days. At least for planning. Sooo much better than it was but lacks of course synthetic vision ■■■■. I’m not a G1000 fan (at all) so I can care less about synthetic-hold my hand- vision.

1 Like

I don’t know what you do for music, but check out Acoustica Mixcraft for a great DAW. It’s pretty much got all the features of Pro Tools at much, much less cost.

I use Studio One v5. It’s fantastic. I have three iPads. One from work and one for music (sometimes two) that are due to remote apps for my keyboards to where they only made remote apps for ipad and in wanting the largest screen of 12.9" at the time. Now I mainly use it over my keyboards using Microsoft remote desktop where I remote into my PC (wireless to LAN and apple to PC). Makes using remote software a thing of the past. :smiley:

1 Like

not working for me. I’m able to ping my android phone from my pc running flightsim through cmd, so i know that’s in the same network. I set the xcom to my phone’s wifi LAN IP, with a port 49555. Then in avaire, set the gps to remote i/O as you mentioned, and set the external listening port option to 49555. still no gps data. I think xCom is working because it’s spitting out random data garbage when I check the log, so I am not sure whats going on with it.

EDIT: lmao, 2 minutes after writing this i ended up exiting avaire (like full close the app on my phone) and then started it back up and it started working fine. LOL

1 Like

Oh WOW! Thank you for posting the details that I could actually follow!

Your link to get the three versions of simconnect was not working but I Googled
simconnect.zip download
and that found the fspassengers webpage for
/?action=simconnect
so I followed the instructions on that webpage, which included a link to download the simconnect.zip file.

Note:
I got xconn started and “Connected to FSX” but at first it still didn’t work in Avare for me because I had forgotten to “enter the IP address of your tablet” in Step 5. After I had followed all the other steps and then entered in xconn the correct IP address for my Samsung smartphone that runs Avare, it worked fine!

THANK YOU again!

1 Like

Just in case this might be helpful to Avare users:
I have just now found a manual for Avare, that was made by Steve. Just Google
Avare documentation - Google groups
and find on the list the link with the heading
Avare documentation - Google groups
Click on that link and it should open the PDF manual for Avare titled
Avare Documentation
That PDF document was Created and Modified 7/31/2018 so there have been several developments of Avare since then, but that’s what I have found so far, and if you know of more recent Avare documentation, please let us know!

1 Like

For some reason your links aren’t working…

Hey guys so… really weird bug with this. I’m not sure whether to take it up with the Avare team or not. For the “GPS Taxi” feature that lets you see where you are on the ground at an airport, it’s now only showing my plane in the very top left corner of the airport diagram. This used to work beautifully, now I really can’t solve this issue. It’s the same behavior with every airport diagram. The tracking works perfectly fine otherwise.

Yep, I’m seeing the same thing at KMHT. It looks like this latest update is missing its georeferencing on the airport diagram plates. Yes, that would be an Avare thing.

It was working fine in the previous data update. I didn’t update my phone, and it’s working there. But I updated the data on my tablet this morning and it’s not working there. And it’s working fine with the Sectional and Approach plates.

I had the same experience where it’s only affecting airport diagrams. I did check on the Avare google group after I checked here, and it looks like somebody else reported the issue, and they’re looking into it. I’m on my phone right now but when I’m back to my PC I can link to it for you.

1 Like

I’m having trouble getting this to work. I can see nmea sentences on xConn so I think that it is talking to MSFS just fine. I’ve got the IP address set to 127.168.0.6:49002 and the UDP protocol box ticked. I’ve got avare set to “Avare IO Module Only” but the map screen just shows my last good GPS fix from the internal GPS receiver and shows “No GPS Signal.” Anybody have any ides? @FlyingsCool5650?

1 Like

127 seems like the wrong IP address. Usually it would be 192.168.1.xx

Go to the menu of the tablet or phone, select Settings/About/Status and check to make sure it’s the correct IP address.

Also, in Avare, make sure you’re in navigate mode and not simulation mode. If you select Menu, it should say “Navigate” on the right.

1 Like

Thanks! I should have caught that IP address issue. Does Avare listen to port 49002 on the same IP address that my tablet is on? The instructions say to set to 192.168.1.6 but my tablet is on 192.168.0.20. My router’s client lists an “unknown” client at 192.168.0.6. Is this the IP that avare is using? I’ve tried both IP addresses and neither of them seem to work.

1 Like

oh, no, I’m sorry, 192.168.1.6 is just an example. Use whatever your tablet says it’s on. And, given it’s probably dynamically assigned, if it doesn’t connect next time once you get it working, it’ll likely be because it tagged on at a different address.I pretty much check my tablet IP every time I want to connect just to make sure it hasn’t changed. It’ll typically only change when you reboot it, or if you leave the house with it and come back and reconnect and there are other devices on or off since you were last home.

Make sure to set the 49002 address in Avare (it’s another choice in the settings GPS menus) and in xconn. It is not the default device. Sorry, I don’t know the significance of that particular address. I read it, I use it, and it works :slight_smile:

Thx @FlyingsCool5650 works like a champ, and loving it. Do you have any recommendations on how I can now get my flight plan from Avare to MSFS without having to enter it twice?

1 Like

I don’t, sorry.

1 Like

Thank you for the excellent instructions, just a quick note. I am running Avare on a Fire Tablet, I followed your instructions to the letter however I did not have the "Avare IO Module Only” as a selection when I went to the Menu/Preferences/GPS/GPS Position Source. I selected all available and it didn’t work. I downloaded the “IO Module addon” from the google store installed it and it worked great. Thanks for mentioning the module in your instructions.

1 Like

You must be using an older version of Avare? Which makes sense with a Fire tablet. The newer versions integrated the IO Module addon into the main program. Glad you got it working :slight_smile:

Worked like a champ, I had to use the Avare I/O connect (using an older version of Avare) but I use that for XP as well so no big deal. Thanks for the tips!!

1 Like