Constant CTD every flight now (ntdll.dll)

Ok , I’m not saying I found a solution, but if I fly the C172 I haven’t had a CTD, really bizarre

It’s just the stock Asobo C172

1 Like

Naw just a coincidence I flew it earlier today and got a CTD.

1 Like

Just to add I thought it was because I did an under volt on my gpu, but 3 hour long flights in the stock C172 went fine even with all mods in community folder
I’m really confused by it all
Will do more testing tomorrow if they haven’t fixed it by then


I know talking about the other CTD isn’t popular in this thread, but has anyone suffering this CTD type not started with a “memory can’t be read” CTD?

I’m just wondering if the two might be linked, by anything other than coincidence, and whether the memory read CTD might be causing the apparent corruption that is causing the ntdll.dll CTD?


Thanks, yeah I thought it was weird, probably if I did another vfr flight it will probably CTD , I’m just reporting what’s happening on my system

There is another thread for the “memory could not be read” CTD. Please keep this topic specific to the recent ntdll.dll crash.


Yeahh and it’s worth noting anything interesting you find even if it is a dead end because if everyone did start saying no issue in a 172 could lead to the start of finding a causation etc

1 Like

Ive done the under volting of my gtx 3070 and then back to video card out of the box settings same ntdlll crashes this weekend, never happened before Friday that we all can deduce now.

1 Like

It was just an enquiry that might have provided some useful information for the devs, but no worries if not.


I did the same, thinking I better reset my RTX 2080 super but with PMDG and FBW CTD

I don’t want to keep banging on about this but it might be something in what I have experienced

I know bubbablitz has tried it with a C172 and he/she got a CTD but why am I not ……well not yet

Maybe if other folk give the Cessna a VFR flight

I normally only fly tubeliners IFR, but I just tried a stock GA aircraft
Like Arrogantobject said it’s probably a dead end but I’m able to fly the sim ……at the moment


Thanks for the tip! I get Windows Hardware errors concurrently with the FlightSimulator.exe Stopped working events. This is kinda unsettling - hopefully this is not an idication that my hardware is causing the CTDs…

Im interested in those who claim they are not getting these errors specific to this thread. So those who can navigate event viewer history and youve not had these dll errors ever how is your setup ? Or are you just doing 2 minute carrrier landings as Maverick? lol

LOL and thats the magic phrase at the moment ‘Not Yet’ there have been a couple other fixes where the for sure this fixes it author comes back and say ‘Never Mind’ LOL…

1 Like

Yeah true, I will be back on tomorrow saying, yep……never mind, back to square one :joy:

LOL there is nothing you can fix so dont waste valuable time you could be playing another game or sitting here in the forums fussing like the rest of us…Remember trying to fix things when there not broken on your end will come back to bite you in the rear… ;p


I made a flight (just finished) from EDDP to EDDL on Vatsim with the A32nx. Had a lot of CTD the days before. Now all went well. Vatsim with AIG modells, live weather, PG, etc. When I arrived at EDDL I looked arround with the drone camera. Maybe I had just luck or they fixed something…

Finished a flight that I crashed during on Saturday.

It allowed me to complete a flight - and we did the same today too, and used Rex Weather to feed in live weather throughout as well as a replacement to the lack of online services having switched it off.

There’s still a variety of other theories swirling around currently too but we just need to wait until we get a fix because for me, my issue with the plague of sudden CTDs lies with an issue with Online Services feeding into the sim

… And we all remember how badly broken Sim Update 5 was with the live weather issue I’m sure!


Pretty obvious folks are getting CTDs left and right… c’mon Asobo, acknowledge the issue and solve it!


They have acknowledged it quite a few times in here to be fair now, and I’m sure someone’s trying to work it out somewhere

1 Like