Constant CTD in Dev Mode

I’m just starting work on a new airport, which I’d previously attempted and made some decent progress with in an older version of the SDK/Dev Mode. After updating to SU7, Dev Mode is constantly CTD, no matter what I’m trying to do. Just switching the camera or zooming will CTD, as will trying to add any items from the object list. Any ideas about this?

hello, it happened to me too, I tried to downgrade the graphics from HIGH to MEDIUM and now I can work in my project.
I don’t know if this is also a reason for crashing but it seems to have seen that I no longer have CTDs

Yes, happening to me too.
I think I have found my issue. When I added a new asset to the modellib I used to run the exe, create and load the package with the new asset. Start FS, open the project, load the scenery, and then try to do something, result: CTD.
Now I don’t run the exe after I add the asset to the modellib. Instead, Start FS, load the project and then add the new asset to the scene. Now Rebuild All and everything is fine.
Hope this helps. YMMD.

I don’t even get that far! I’ve literally just created the project or selected the Polygon option and laid a point, then BOOM…CTD

Not sure if it is related but I am getting CTD too with Dev Mode