Controller bindings and Control Options - Do not work as specified

This is a PC issue. Besides losing your mappings completely, it seems to me that the mappings for the XBox 360 style controller (on my PC) do NOT DO what they say they do in the mappings, and DO some thing that they do not say in the mappings. It’s hard to say for sure as there are 68 million options in there, but here’s what I see:

  1. Go to controls options and use the nice SEARCH BY INPUT to search for the X, Y, A, B buttons. Actual Results: A bunch of combinations are shown (X+RB, etc) but only two mappings for say, X, but the things that it says X does don’t work. X is mapped to COckpit Interaction Secondary Action (Lockable) but I’ve tried 100s of buttons and knobs, some with secondary and tertiary functions, and X does not do anything at all to the button. What it does seem to do is increment the throttle position, which, when I check, is NOT mapped to the X button. It’s like there’s several mappings fighting each other for the same controller.

  2. Try clearing everything out for X, and still it does the ghost function that is not mapped. Map something else to the throttle increase function, and still X is increasing the throttle.

  3. When I want to clear something, I get to the mapping window and it says press key or key combination. Nothing I do, including pressing clear current input then validate, works. the Window stays open until I select another button. This happens up to 20 times in a row before the VALIDATE button accepts any presses after pressing CLEAR.

I have had that happen occasionally.
After you clear current input, try select an input.

Is anything showing up in the “search by input” window when you try.
It sounds like something is sending a spurious signal.

1 Like

Sending a spurious signal.

I thought that also, and I tried pulling all my USB peripherals out, and at a certain number (1 or 2 peripherals plugged in) everything is fine.

Good luck anyone trying to map a home cockpit who has 30 or 40 usb HID joystick controllers equivalent.

Me, I’m just a moderate simmer with four things (an xbox controller, a flight stick, a yoke, and rudder pedals).

Is it any specific ones, or just any 2?
Would a powered USB hub be any help?

Hubs made it worse, but a windows update and a bios update made it much better.

It seems that my Dell ALienware had some bios/motherboard issues.

1 Like