Crash after crash after crash - What's causing it

I’ve had no issue since purchase the week of launch last year.

Since update 3 I’ve had 6 system crashes.

All times, <10 mins into flight at around 10,000ft mark. It’s not when it hits this, last once was at 11,000.

Only add on is
1x Livery
1x A320NX (dev mode)
1x Orbx WSSS - purchases in Sim

Sim freezes. One last stutter then closes to desktop.

WHAT is doing this.

I got WSSS add on the day before Sim update 3. No issue before but only did 2-3 take off landings.

Remove ALL of them, see how stable you are. Multiple test flights in vanilla.

Add one, rinse and repeat.

Stable? Add another. Rinse and repeat.

This is Change Management when you have materially impactful mods affecting Aircraft, Avionics, graphics and scenery. Add a core sim code push that affects two out of the three? “Earth shattering kaboom.” - M. Martian.

That’s complete BS. Why am I doing field testing and troubleshooting? I’m the customer here.

Livery I can accept but it’s happened with that removed.

A32NX - The most popular addon. Why aren’t updates being given early to developers to ensure compatibility?

Orbx WSSS - Purchased via the in Sim Store. It’s should be compatible and tested as it’s a instore payware addon. It’s what we should expect with goods we’ve purchased.

Okay.

Mods aren’t written by Asobo, in most cases not certified or even guaranteed for compatibility. The burden is always, always on the third part maker.

That’s how it’s been in FS ecosystem going back almost two decades.

check event viewer…

Some liveries require updates to work with the latest version of the A32NX.
Please make you check for any update of that livery, if it is not already up-to-date.

I suggest uninstalling Orbx WSSS and just testing if it makes any differences, some sceneries also need to be updated after sim updates.

Try to test vanilla… and see how it performs. If you run the sim without any add-ons for a longer time, are you still getting the hang and crash, maybe we can go from there.

Nobody wants to spend a lot of time troubleshooting but when the sim crashes and hangs you will need to be open to try different things to try to get it to work again.

This is one of the places for help, you also have the option to chat about the issue on Discord in the #communty-support area but please give some of the suggestions :point_up_2: a try.

I have the same problem. MSFS always crashes no matter which mod I use or not use. Without mod it crashes later, with mod sooner…
I only use Just Flight Arrow III and the G530 mod. Without using these mods, I cannot fly proper IFR as vanilla state IR is useless arcade and a waste of time. So once again back to P3D or the expensive certified AATD… so sad

I can’t say I’ve had no issues, but arguably very, very few.

Until now.

Even with an empty community folder and a 100% complete “clean” reinstall just this week, I’ve been grounded since WU3. The latest update - SU3 - was like rubbing salt in the wound.

2 Likes

Same boat. After the update, I have tried everything (almost) up to the point of updating the BIOS as they say it can also be the issue. No luck so far. It is not my system, I’m running on 3060 Ryzen 7 5800 and as everyone else, other “heavy” games are running smoothly.

The game is awesome, if its running.

Something about your system is obviously different than those of us who play the sim without any issues.

Oh sorry. I thought it was given, I meant power wise.

It took me 3 weeks to solve my issues. SU8 is causing problems.
I can only suggest things that helped me.
Have you tried running the sim offline?
Turn off wifi and pull the ethernet cable.
Are you doing any overclocking of any kind?
Running other demanding games without problems means nothing when it comes to FS2020. Since SU8 the game is very finicky. It loves to crash/hang-up/ and just shut down on its own.
You should be able to get it running eventually.
I know it is really not very encouraging but still wish you good luck.

1 Like

Thank you for this. I have tried.
-Vanilla State (re-download all 130gb+)
-Delete user profile in steam
-Uninstall, reinstall MSFS
-Community folder empty
-Downgrade graphics card driver to working
-Upgraded graphics card driver to latest
-Updated BIOS
-Updated windows version

How do you run the sim offline if it is checking on the restart? I tried turning off the internet after it have booted (installation manager window), and still nothing. Unfortunately, I can’t refund anymore. I will if I can.

there are much much more possible variables, like sound drivers, win updates, virus checkers etc.
since the vast majority of players run it fine…its a combination probably and these can be very hard to find.
good luck.
its sad to see those issues will eliminate some of the casual players.

1 Like

It was running perfectly before the recent 2gig update. Having a blast actually.
Unfortunately my luck ran out, it’s a pity now that I have gone past the learning curve and when the stick controller is just 1 week old. :no_mouth:

btw, NVIDIA drivers also update the sound card with it. Only rely also on windows defender for the virus part. I have tried it as well. If I’m not able to refund it, then it will probably stay in my drive waiting for an update fix, if ever there is one.

thanks anyway.

Are you on the steam version?
The game will run off line.
Unplug your router so you are isolated from the internet.
run the steam interface. then run fs2020.
There are a couple of problems concerning your post.

  1. You tagged onto a 1 year old thread.
  2. you provided no info on your system.

It took me 3 weeks to figure out what was wrong on my side of the situation. It turned out there was a problem with my router. That is why nothing I did on my pc was ever going to fix the problem.
Can you take your pc to a friends house and try it?
As crazy as it sounds that would of fixed my situation.
Waiting for Asobo to fix the problem may never happen…

When I saw “crash” on the search function, I immediately jumped in not paying attention to the dates. Maybe the search sorts it out showing the most popular anyway. Just tried it now, disconnecting the internet does not solve anything. Thanks for the help. I’ll keep trying, but not so hard now. I gave up on hope.

AMD Ryzen 7 5800x 8 core
TUF Gaming X570 Plus
32 GB RAM
Asus RTX 3060