Crash on switching to VR on Quest 2

I’ve been struggling with this for two days after buying the game but so far was never able to launch it in VR mode. It ALWAYS instacrashes when I switch over.

I’ve done DX11 and DX12, tried different OpenXR setups, removed OpenXR toolkit etc. but it has no effect. The game is on steam, family shared to my main account, I repaired the game (basically redownloaded it again ;_;).

3090, 3700x, win10

I’m gonna take any advises at this point, I have no clue what to do and the game is basically unplayable.

How are you connecting? Airlink or cable or virtual desktop.

Upto about 2 months ago msfs was very stable for me, now I get numerous ctds.

I use airlink to connect and have found launch oculus app, ott and setup airlink before launching msfs20 after loading flight in 2d I then switch to oculus and it usually works.

Hope above method helps, I think msfs either ctds, or freezes or I have to end task 4-5 times every time I use msfs before I can launch it successfully.

Yes, establish any link that’s viable first, set up the flight in 2D, then switch to VR after hitting the fly button.

Unfortunately, it’s the same story. All goes black in the goggles, the Quest “sand clock” spins and the game crashes to desktop.

Turning off “Game Theater” in steam doesn’t help.

I connect through airlink. Are there any logs I can check? Is there official MSFS support or something I can actually continue to to look at my case in detail? Because this is straight up unpayable and because of how long it takes to download the game on steam even a single time it’s unrefundable too (Between two downloads and hours of testing I “played” 30 hours now without being able to do a single flight).
I think the regular random troubleshooting is just exhausted at this point, anything I can google about CTD like this, while being very similar, doesn’t seem to be my issue and is solved by steps that don’t work for me, so unless someone shows up knowing exactly what’s wrong by chance this isn’t gonna be solved.

EDIT: The system reliability pins the crash to exception 0xc0000005 with the path C:\WINDOWS\SYSTEM32\ntdll.dll

Faulting application name: FlightSimulator.exe, version:, time stamp: 0x6409dda0
Faulting module name: ntdll.dll, version: 10.0.19041.2130, time stamp: 0xb5ced1c6
Exception code: 0xc0000005
Fault offset: 0x00000000000a2337
Faulting process id: 0x65c8
Faulting application start time: 0x01d95af9f024fa69
Faulting application path: K:\STEAM M.2\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: 5d0e6510-b824-4c71-94ff-6bb9d2ec5e42
Faulting package full name: 
Faulting package-relative application ID:

I’ll try to poke around that for now. I fixed any corrupted files I had with SFC scan, but unregistering / reregistering NTDLL.dll, replacing it etc. is probably not gonna be an option. It’s probably not an issue considering other VR games work perfectly.

Nahimic services are a potential issue but so many people have them I also doubt it, and they are VERY difficult to remove meaningfully.

Will either need dev’s support at this point or just wait for MSFS update, which is very disappointing. I tested out beta branch of MSFS on steam and it didn’t make any difference either.

MSI Afterburner was causing this. Have to keep it turned off.

You have to turn off every background process you can afford to turn off (sound services, VR/Performance related apps, unrelated apps) and launch MSFS only after that. VR started working after I killed enough things, and then it was a matter of turning on one program after another while relaunching MSFS until it no longer worked again.

1 Like