Crash to desktop without error message

No improvement over the Sim Update III
Today’s CTD is under N 46.044397261415 E 6.1535083240597 - IFR flight at cruise level after 2 hours. It’s really frustrating

Note on my side adding the below on FSUIPC 7 Ini file solve all CTD…

There is something called CTD Vaccine that has a thread on the Avsim MSFS 2020 forum. It involves a small change in the registry and the instructions that are posted about this Vaccine are very easy to follow , and it is easily reversed if you don’t see any benefit. I was averaging about 25% of my flights ending in a CTD. I installed this Vaccine 4 days ago, have since flown about 15 flights, and not one CTD.

You may ask why don’t I post this fix here, and it is because it involves a small change to the registry, and I wouldn’t want to be responsible for someone messing up their registry. If you are interested, go to the forum on Avsim, search for CTD Vaccine, read it and try it if you want to. I am sold on it at this point.


after today’s update I tried a flight and Oh surprise, none the PFD, ECAM, every display is off, tried to turn it on and nothing, tried Ctrl + E and nothing!
Does anyone know abt this issue, I have the FBW version, I’m updating to see what happens!
I’ll keep u updated

Update: Fixed with an Acft update

Hi Jhonny,

it’s not a CTD :wink:

Beside of the used mod the KNOW ISSUES mention such display issue too:

  • On rare occasions, Aircraft screens might not initialize correctly upon loading a flight. Please restart the flight to fix the issue.

The reproducible CTD I reported in 100% reproducible CTD at specific coordinates for months is still not fixed with the latest update and they conveniently locked that thread… :neutral_face:
My patch from that thread is still working though to fix that CTD.

I remember that! I would imagine these crashes are very far down the pecking order.

My avionics die after about five minutes. I can keep flying (172) using the basic instruments but have no flaps either. Thoughts anyone?

Other than you being lucky its not a CTD, no. :wink:

Avionics dying sounds like you have either forgotten to turn on the alternator, or it is on, and you are still able to drain the battery. Possible causes could be leaving the starter motor on, all the lights etc.

Thanks. Have to laugh (instead of crying) . Started checking the alternator and battery assignments on the yoke, I was intending to write down the default settings then turn them off and see what transpired. Bloody thing CTD within a couple of minutes of going to Controls. But I will persist. At least I have another dump file to send to Zendesk

1 Like

I tend to agree with you myself. I’d say 85% of my CTD’s lately have been on my landing. In fact, it’s usually just after I land and start taxiing. I’ve gotten my CTD’s down quite a bit after a clean install of Windows and FS again, but still getting them when I land most times.

I crashed to desktop 3 times tonight, never completed a flight. No problems loading the flight and getting airborne but crashes before I reach desttination.
i9 10900KF, 64GB Ram, RTX 2080 super, Asus Z490-H mobo.
My specs are more than adequate and I’m not running out of memory as other than Windows there is nothing else installed on my PC, even Windows in on a seperate NVME to Flight sim ??

After a few more tests on my 6800XT, it seems that setting AMD Radeon Software → Performance → Tuning to Manual without actually enabling anything isn’t enough. MSFS may still crash even in the main menu after 5-10 minutes at most. However if I set Fan Tuning → Max Fan Speed to any value (I usually go with 75-80%) and also Power Tuning → Power Limit to 15%, the game seems OK as I haven’t had a single crash in over 10 hours of flying. These may not be absolute values and I may not even have to enable both, so I’ll keep testing.

1 Like

I have seen this a few times now. I think in every case it was the key still in the start position rather than both.

1 Like

Yep, I did that in the Savage Cub once.

Can anyone confirm if they have fixed the “simconnect” CTD issue with the latest update? I was only getting CTD with AI traffic enabled and I haven’t turned it back on yet.

I still get the simconnect crash.
More times than not still, it ends my session.

I just this CTD:
Faulting application name: FlightSimulator.exe, version:, time stamp: 0x6040b793
Faulting module name: CoherentUIGT.dll, version:, time stamp: 0x5fc6aa59
Exception code: 0xc0000005
Fault offset: 0x000000000013edb2
Faulting process id: 0x808
Faulting application start time: 0x01d71a3b20b54396
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.14.5.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.14.5.0_x64__8wekyb3d8bbwe\CoherentUIGT.dll
Report Id: 393ba6ce-00cf-4322-bd37-1214eaf1d65c
Faulting package full name: Microsoft.FlightSimulator_1.14.5.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

CoherentUI is the UI Framework they use I guess ?

Any idea very welcome

Well over a week with CTD vaccine, 3-4 flights a day, and not one CTD. I used to get around 2 a day before the vaccine.

Coherent UI is used for avionics as well. What aircraft type did you use when that CTD occured?

I haven’t been botherd too much by CTDs, but on a (basically sterile) new machine (AMD 5950X + Nvidia RTX3090) I frequently get the very same CTDs from CoherentUIGT.dll, but EXCLUSIVELY while flying one of the airliners (B747-8, B787, A320). This occurs with the corresponding mods as well as with an empty Community folder. I did not yet manage to reproduce a CTD from CoherentUIGT.dll while flying the TBM, Baron, C172 or CJ4 (with or without mod).

So, to me it looks like there is a bug related to the airliner avionics, I already reported that to zendesk. Interestingly, not everybody seems to be affected, so hardware, driver or settings could be involved as well.