Crash to desktop without error message

Hmm…
All things being equal, I think I’d have to reluctantly, VERY reluctantly, admit that it sounds like something changed in MSFS.
:grimacing:

Is it just me but something that I seem to keep seeing in many of the troubled systems, though, is mention of the Ryzen CPU. Probably just me…

It’s nice to read messages about people who have CTDs, who are doing analyses, trying to figure out where the problem might come from.
It changes parrots who do not know how to repeat tirelessly, that the problem is necessarily you.

On my side, after having flown for 15 hours in all without CTD.
Yesterday on a flight with the Spitfire from LIRE to LOWI. I got a CTD after about 30 minutes, with vcruntime140.dll error
I started the flight again, same after about 30 minutes, CTD with vcruntime140.dll error.
Earlier, I did it again with the Corsair, same thing, after about 30 minutes, CTD with vcruntime140.dll error.

I made another flight trying to bypass the area where I had the CTD.
I flew over an hour without a CTD.

I read, here on the forum, it seems that a simple wind turbine, could cause a CTD.
The guy had rebuilt a very small area on the map, which caused a CTD.

I crossed Spain from north to south, with the Corsair without CTD

Yesterday I had my first CTD in months, without any warnings or error messages.

Z390m gaming mobo
i9-9900 CPU
RTX 2070
64GB of RAM
WIN 10 v10H2
Nvidia drivers 461.92
Game on its own 2TB SSD

Apart from that, I still keep on getting those awful “package” error messages from time to time…

If there was not only one person in 100 who specifies their PC configuration in their message, we could draw some conclusions. But here, we can only assume …

To be clear, nearly every one here that has put a ■■■■ load of hours into helping many users eliminate CTD errors or at the very least reduce them, has clearly stated, MANY times, that the sim has issues that need attention from the developer. We have ALL conceded that not all errors can be solved by the user.

What I am hearing from some other users is that it cannot be a misconfiguration or conflict in our computers that cause some of these errors. These statements are being made while at the very same time those users are making adjustments to their computers in an effort to reduce the failures. This would be what we call irony. If it is ALL Asobo’s fault then why bother testing different configurations on your system.

Instead of bashing those that are knowledgeable, although obviously not to the lofty levels of others, and willing to set aside copious amounts of personal time in an effort to help those that are banging their heads on their desks, maybe we could ALL agree that…
although there are some serious shortcomings in the current Asobo code, it is possible that, some are the result of configuration or compatibilities. Some users CTD errors can be the reduced through local troubleshooting and baselining of their system.

By recognizing the middle ground in this long argument, I am betting that many more will be flying before Asobo gets all the code issues squared away.

3 Likes

It’s kind of like that…

After the following:
Completely Un-install MSFS APP
Un-install ALL Nvidia Drivers
Un-install ALL C++

Re-install C++
Re-install Nvidia Drivers
Re-install MSFS APP

In the Game started at mid rages graphics settings and adjusted to Ultra at 4k at a frame rate average of 30± FPS. My longest flight at those settings in a C182 so far has been an hour and a half w/o CTD. Probably could have kept it going but, I was flying VFR, by hand w/o AP and wanted to stop to get that $100.00 hamburger.

1 Like

And for you, can we judge the effectiveness of what you did, like many people, on a 1.5 hour flight?

Just mentioning what’s worked, for me. Nothing more. So, maybe? Maybe not?

The longest flight I did after trying modifications was 11 hours.
Without changing anything, on another flight, I had a CTD 3 times in a row after 30 minutes.

To say that a solution “could” work, it is necessary to repeat the same flight which had caused the CTDs.

Well, as I’m in the Civil Air Patrol here in NC I typically fly the same routes/search patterns in my area of responsibility. That is, NE North Carolina (KECG) as far west as KRWI and as far south as KEWN. To fly a C172 or C182 for eleven hours, a wee bit un-realistic. I don’t fly heavies.

This 11 hour flight, I did it with the 747, but that’s not what I’m interested in at all, I did it just to do a long test.
I prefer “small” planes, flying at low altitude to enjoy the landscapes.

As I said above, I read that an object on the map, as small as a wind turbine, could cause CTDs.

I came across another subject, a person who had never had a CTD.
I asked him to do a flight that caused me CTDs, he also had a CTD.

For sure…

I have been in their position… I was sure one of my problems was software that caused a BSOD. But, after trying the same, re-install OS, Application and getting the same issue. I know it is super frustrating.

I had a system that was crapping out after playing a new game (something new a few years ago). My initial suspect was overheating GPUs (I had two 1080ti in SLI mode). I removed everything including GPUs and using the microprocessor’s internal GPU. This narrowed the problem down to the CPU, a pair of M.2 SSD (RAID 0), the motherboard, and 1200 Watt Power Supply. PSU was old so I measured the voltages with a scope, watched for unstable voltages (5V most important) and stressed the machine until it crashed. PSU remained solid.

I also removed my CPU heatsink and re-applied new thermal paste. It looked dry, could have been it? Nope, still crashed. Either case, I replace the thermal paste every few years as a precaution.

Long story short, Removing the M.2 RAID solved my problem. I remember someone said I should not use SSD in RAID. They could not explain why so I had my disbeliefs. Not anymore. I went with single M.2 for OS and a separate SATA SSD for games. Worked great after that.

1 Like

yup…also crashing with black screen,pc freezing witn no CTR ALT DEL working and needed reboot.Randomly but i think it has to do with other apps running along the mfs ( i use bandicam,movavi video editor,replay addon etc) and i have 32 gigs of ddr4 and an 6800xt nitro plus.
No other game does anything wrong.
No stress test has ever proven anything wrong.
This is messed up !

Just west of KECG, we have a wind mill farm. Pretty well represented too. So, those objects, for me, cause no CTD as I’ve flown over/past them on many occasion with no issue.

For whatever reason it seems a bit more stable in the last couple of days as I hadn’t had a single crash while entering main menu or returning back to it. A couple of 40-minute flights with C152 with lots of back and forth between MSFS and Windows (Little Navmap etc), were 100% successful. I had a couple of hiccups in the latest flight with huge framedrops for 5-10" while preparing the aircraft for taxiing, but other than that it went very smoothly.

I’ve no idea why yesterday it kept crashing with CJ4 WT 10-20 minutes into the flight. Let’s see what happens today when/if they release the new huge update. Also in a few hours I’ll hopefully receive Honeycomb Bravo after 4 months of waiting for Aerosoft (6 if you count the original cancelled Amazon order), which will complete the Honeycomb set. I should be excited but I’m not, because unless MSFS gets stable on my system there’s no point in investing additional time to setup up yokes, buttons, radio panels and throttle quadrants.

I have exactly the same problem… I posted this in another thread as well but…
I updated everything, Content Manager stuff, even my GPU Driver and my entire PC and it still won’t work…

I was flying pretty well and all of a sudden I lost connection and it told me “You have outdated content, do you want to update it and return to main screen?” or something, I presses “No” because I was in the middle of a flight…and the only thing that happened was that the same window popped up again…and again…and again…and…you know what happened next by now…
anyways, I hit yes because of frustraion and i was put into the “Press Any Key To Start” Screen…and after pressing a key, you might already know what happened…exactly, back at the “Press any blablabla” screen…and again and again…

After everything the sim just keeps crashing to desktop after like 1 minute at max in the world map…
frustrating

Also I have the premium deluxe and I’ve heard that even GamePass flightsimmers have the same prolem

I just did the IFR flight (I don’t have Navigraph) from Barcelona to Ibiza with the TB 930, I didn’t have a CTD.
I did all the taxiing, to the parking lot, with the engines off.

You didn’t say what error you had in the Event Viewer.

Motherboard: MSI MPG X570 GAMING PLUS
Processor: Ryzen 5 3600
GPU: RX 6800 XT RAM: 4x8 GB at 3200 MHz

I was wrong, in fact the guy is talking about an area that causes CTD next to a wind farm

For my part also, I have much less CTD, I am still on the Windows that I call N ° 1 the one on which, it was impossible for me to fly more than 10 minutes without CTD.

Since I uninstalled Microsoft Visual C ++ (without reinstallation), I have only had 3 CTDs with the vcruntime140.dll error, but each time on the same flight zone, or at least at the end of the same flight time.

On the other hand, I always have the impression of being on the razor’s edge, and that at any time, I can have a CTD.
I hardly dare to alternate between interior and exterior views. I was thinking of buying a Thrustmaster T.16000M FCS type joystick, or something. Or why not, do something to me in 3D printing, but for the moment, I will do more, with the Xbox One controller.

1 Like