Crash to desktop without error message

At the end of the day the error you are getting is pertinent to your set up be it hardware, software or even just an unfortunate compatability issue and yes there will be others with similar problems but if it’s not fixable to Asobo then what can they do? Without stating the obvious VCRUNTIME140.dll is Microsoft software rather than Asobo so maybe that’s where you should be directing your ire. For sure Asobo will get higher priority but if it’s a Windows issue they still have to put in a ticket just like anyone else.

With all the respect, I’m not sure you understand the VCRUNTIME140 issue properly.

The exception is occuring there, in memcpy, because the caller is sending a null pointer as the destination. It has nothing to do with Microsoft as any piece of code sending a null destination pointer to this function is going to generate an access violation.

According to many forum posts, and especially thos who took the time to get a decent crash dump, a significant amount of crashes are generated by the Renoir library - accounting for more than 90% of my CTDs. Again, this is a 3rd party piece of code used by Asobo.

I am sorry, but in 2021 (and even decades before), exception handling has been available to developers to prevent application crashes. Clearly, this library does not, in the offending area:

  1. Make sure it does not send a null pointer to memcpy.
  2. Protects this code section with exception handling.

As usual, without the source code, it’s hard to provide a proper analysis.

Anyhow, this remains an Asobo issue, either by asking its provider to fix their sh1t or by getting rid of this library.

I still hope this discussion will become obsolete after SU5.

3 Likes

Yes that just about sums it up. It is obviously an essential process or they would get rid to be sure but how come it only affects some users? Surely there must be a common denominator for those that are struggling?

Well i really do, and i already reinstalled Xp11 although i really would prefer msfs due to the better scenery and interface. But i can’t get it to work or even install anymore.

Well said. Exactly the same here. Everything was perfectly fine for the first 4 months or so, and since then it’s constant CTD.

and have you in meanwhile tried to disable your overclocking setting ?
: VCRUNTIME140.dll Error - #219 by kityatyi

Overclocking was present on release day.

Same here, I never had C2D and now it always crashes. I fixed and reset the app. After installing the last driver it lauch but now, it won’t. I would start it to update, maybe the patch is in the update…

There is something changed somewere in windows. Maybe an update. The xbox bar crashed too, and after fix and reset, it launch but no luck with MFS.

“now” means these:

?

Just wait a moment and try to let install the update again.

EDIT
PS: I mean the whole topic, not in special these post. But @sneaky74 like it, so I let the link stay :joy:

1 Like

I tried on Sunday and it won’t launch. After nivida driver update it worked bur I lauched it one time. I don’t know if the issue was resolved.

You think, it crashes now because of the MS server overload ?

ah… Sunday… then these was an older issue.

To be sure whether you now run into the update-issue, which some users affects:
Can please you open the windows event viewer and searching the exact logged error message ?

1 Like

That would be my guess yes.

There was a potential work around in the previous post’s link which involved starting MSFS from the Xbox Store app and waiting for the update screen to find the download - if it reports needing 22.92 GiB additional disk space instead of 0 GiB then you should be good to go.

1 Like

Thanks for your help.

I have this :

Nom de l’application défaillante FlightSimulator.exe, version : 0.0.0.0, horodatage : 0x00000000
Nom du module défaillant : AudioDevProps2.dll, version : 2.6.4.0, horodatage : 0x60b0a9e5
Code d’exception : 0xc0000005
Décalage d’erreur : 0x000000000001ba66
ID du processus défaillant : 0x3b5c
Heure de début de l’application défaillante : 0x01d7830c132d209c
Chemin d’accès de l’application défaillante : C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.18.13.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Chemin d’accès du module défaillant: C:\ProgramData\A-Volute\A-Volute.SonicStudio3\Modules\ScheduledModules\x64\AudioDevProps2.dll
ID de rapport : c09f2f29-63e0-48ef-8635-6c1ccb8a8dda
Nom complet du package défaillant : Microsoft.FlightSimulator_1.18.13.0_x64__8wekyb3d8bbwe
ID de l’application relative au package défaillant : App

Audio driver issue ?

@Sneaky74 : I have Xbox game bar and “Compagnon de la console Xbox”. No Xbox Store. I have the DVD version.

these looks different than the download issue and I see alread a “1.18.13.0”

And these A-Volute s…t…

Have you installed tools like Asus Sonic Suite / Radar ? Please uninstall all these stuff.

Then also open “services” , search a service called “Nahimic” and “Disabled” it ( right mouse → start type: disabled ).

2 Likes

The audio ‘crash’ I believe is a red herring, probably just the system getting ready to play the download music.

Whiskey Tango Foxtrot is that service ??? I only disabled it.

It’s running :smiley:

I have now the lost connection error. I’ll wait for the servers unloading.

Many thanks !

EDIT : It’s updating… 40 Go with ADSL 22Meg. :smiley:

2 Likes

tools like these Asus Sonic… install and use these Nahimic service. You not need these tools and you can de-install these too. The FAQ mention these Asus Sonic stuff already as possible incompatible :slight_smile:

1 Like

Audio apps drivers and hardware have always caused problems for many folk in the past, call it habit but I always look there first

1 Like

I’m glad it’s downloading, because I didn’t know how to respond to the DVD version LOL. Nice one :+1:

1 Like

lol, It’s gonna be okay. I’m like someone in front of the closed toilets door.

2 Likes

Game keeps CDTing at different states. Inflight, in Loadingscreen to RJTT, on the menu, in the settings. There is not a specific situation, it happens randomly since the update. Never had that problems that constantly before.

1 Like