CTD after Sim Update #5. Can't get into a flight

Edit: I tried limiting my framerate to 30 in Nvidia Control Panel and I also tried disabling live traffic. Still crashing every time.

2nd Edit: Now it also crashes on the world map.

3rd edit: Issue resolved. No more CTD for me. See post #14.

My community folder is empty.

I’m using developer mode. I tried it with developer mode turned off and it crashed, so I turned it back on.

Brief description of the issue: Menu loads fine, I can enter the world map and set up a flight plan. Upon attempting to load any flight, there is a CTD with no error message.

PC specs: HP Omen laptop with i7-9750H, a GTX 1660 Ti and 32 GB of RAM. The game is located on a 7200 RPM USB 3.1 HDD.

Version: Steam v1.18.13.0

Did you submit this to Zendesk? If so, what is your ticket #? - No I didn’t, considering this seems to be a widely reported issue.

I completely removed MSFS from my computer and also removed any associated files I could find, then I reinstalled from Steam and ran a 112 GB update in the MSFS updater. The issue remains.

Same issue here, did the same thing you did with the reinstall, still can’t enter a flight.

I’ve tried various things that I found worked for other people in other posts, but none of those workarounds have worked for me.

I have laptop with same specs (Omen 15"). I also had CTDs in menus, attempting flight etc. I had overclocked the 1660Ti using MSI Afterburner. I have now turned overclock off, and everything has worked for the last couple of hours. Have you overclocked maybe?

Same issue as the rest CTD no matter what I do. Sim would ran nonstop before with only a few lags.
Alienware R11 Intel i7 10th gen 3.6Ghz OC 5.1Ghz
Windows 10
Nvidia RTX 2060
32 GB Ram

Do you all have laptops?

I have a Lenovo AMD Ryzen 7 5800H with Radeon Graphics, RTX 3060 and 16GB of ram.

Might be the key why we have this very specific and consistent crash.

Welcome to the club, let’s hope for a fix soon

I have a laptop, but it seems the crashes when clicking Fly and in the World Map are happening in desktop computers too.

If you have CTD during/after loading flight, did you try checking and disabling AI Traffic?

Same issue for me. I did get it to work after I turned off the rolling cache and limited the frame rate to 30 FPS. Prob not a great fix but it did perform very smoothly and loaded in 3 min.

Same here with the crashes after about 7 minutes of use. After one CTD I got this:
Flightsimulator.exe Application Error
The instruction at 0x00007FF750711A15 referenced memory at 0x00000196F891D000. The memory could not be read.
I have emptied Community folder with no effect.
I have uninstalled Afterburner to no effect.
I have set Vsync to On with 30fps limit to no effect.
I have set traffic to Off to no effect.
Blah blah blah blah…No effect.
I have a desktop pc. I don’t know if this is more pronounced on laptops but I don’t think it matters.
This CTD problem also seems to affect all different types of PC setups. I really REALLY hope they are working on a fix because this is ridiculous.

Mine crashed to desktop every single time I load the sim, within about 30 seconds or so. I can’t even get close to setting up and starting a flight. I’ve tried everything including a full clean re-installation. No community folder mods or anything. Amazing with all the resources Asobo has (someone said 500 people working on MSFS I think?) they can’t bring out an update without making the game literally unplayable for so many people. And I don’t mean, so many bugs it’s unplayable. I mean CTD immediately upon loading. What a joke.

I resolved my CTD issue by performing a truly clean install. I missed a folder before. There are two AppData folders, one in Local called “FlightSimulator” and another in Roaming called “Microsoft Flight Simulator”. I only removed the Roaming folder, I missed the Local folder.

Conducting another reinstall and deleting both AppData folders solved all of my CTD issues.

I solved mine by installing it on my internal SSD instead of my external one. Don’t know why that made a difference, but it did.