CTD at Flytampa (Marketplace) EKCH with empty community folder

Hi,
Just wanted to post to hear if anybody else is having the same issue.

I am consistently (four attempts now) getting a CTD from the loading screen after selecting “FLY” with the following setup:
Gate B16 at EKCH having the Flytampa scenery installed. My community folder is empty and todays MSFS hotfix is installed.Automatic server is selected, live weather, all players, air traffic off. No flight plan and no arrival airport selected. A320neo with default livery.

The CTD happens with about 60-80 percent of the blue loading bar complete.
Event viewer is reporting (Norwegian version):

Programnavn med feil: FlightSimulator.exe, versjon: 0.0.0.0, tidsangivelse: 0x6038d404
Modulnavn med feil: ntdll.dll, versjon: 10.0.19041.844, tidsangivelse: 0x60a6ca36
Unntakskode: 0xc0000005

Running the latest Nvidia drivers 461.72
I5-10600K (not overclocked)
MSI 3060ti Ventus 2x
Win 10 Home 2004

All the best,
Alf

Do you also have FlyTampa KLAS installed? It appears MSFS has issue with EKCH and KLAS containing the same folder name. The following change to KLAS fixed my CTD at EKCH.

  1. Rename the subfolder FlyTampaMatLib to something like KLASMatLib
    \AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages\Official\OneStore\flytampa-lasvegas-airport\MaterialLibs\FlyTampaMatLib

  2. Update layout.json file for KLAS by replacing ‘FlyTampaMatLib’ with the new folder name (e.g. KLASMatLib). There are 4 rows that need to be updated.

5 Likes

Thanks alot - that worked brilliantly!
I have a Zendesk query ongoing on the same issue, will notify them of this KLAS/EKCH issue and your fix.
Thanks again!!
Alf

Thanks X2!
I had those crazy crashes and your fix worked 100%

“…stays in Vegas”??? or do I have to edit this after every update?

Btw. Thx for the workaround, it sure did the trick. BIG :pray: