CTD at initial loading screen

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
I had the CTD, emptied community folder but CTD continued

Are you using Developer Mode or made changes in it? NO

Brief description of the issue:
On initial loading of sim it gets to the screen with the part where the music starts then immediately crashes

Provide Screenshot(s)/video(s) of the issue encountered:
I don’t have screen shots but here is a copy and paste of the event log:

Not available



Detail steps to reproduce the issue encountered:
Load the sim, crashes at screen with music and UK scenery

PC specs for those who want to assist (if not entered in your profile)
Ryzen7 3700X
32GB DDR4 @ 3600
Nvidia Geforce 2070 Super
1TB Nvme SSD

Did you submit this to Zendesk? If so, what is your ticket #?

Also wanted to add that I had gotten a couple of 'Packages out of date" error messages and on one of them I did not click continue as I was in the middle of a flight. Not sure if that may have something to do with it.

Maybe a fix from this zendesk article might help you? Did you try updating your GPU drivers?

For the packages out of date check your content manager and see if you don’t have some US world update content that needs to be updated

Thanks for your reply. I double checked and have the most recent driver (465.89 3/30/21) and still have the CTD. Also how can I check my content manager when the game won’t load?

Your last note on your first post made me assume the CTDs were inconsistent.
Did you try some of the solutions from the Zendesk article? Things like fast boot or logging in and out of the store are things that have helped a few in the past.

Sorry for the confusion. I just mentioned the packages out of date because I saw that it was a known issue and it had popped up a couple of times the last couple of days before the sim stopped working. I’ve gone through the article and I think I’ve done everything except the clean install. I tried the fast boot and the logging in and out of the Microsoft Store account but same results. Crashes at the same point right when the music starts on the loading screen. I also saw a reply in a different thread from someone that seems to be having the same CTD as I am since yesterday.

Not sure if this helpful but here’s a shot of what AppCrashView is showing. The exception code for each crash is an “access violation”.


for these errornumber exist some threads. You can use the search function with the error number.

This kind of issue comes often from the windows virtual memory ( pagefile ) settting, which is too low.
Sometime it is caused by joystick setting, then you can try to start without connected joysticks. Also try to delete the RollingCache File.
Last both in special because these sync-issue.

Ok thanks. I clicked the “reset app” and it’s apparently re-downloading the sim so I’ll have a to wait a bit. Hopefully it fixes the issue but I’ll check these things if I’m still getting the crash. Thanks for your reply!

hmmm… not exactly sure what “reset-app” do. If the guess is correct, a property from your settings file cause the problem. Let us know whether the reset helped :slight_smile:

The “Reset” will force a full download. It is similar to how the Steam “verify file integrity” is for MSFS.

MS Store has “Repair” and “Reset”.
How to repair or remove and do a clean install of Microsoft Flight Simulator on Microsoft Store – Microsoft Flight Simulator Support (zendesk.com)

1 Like

I have the exact same problem as and it started yesterday after many many of zero crashes. It’s redownloading from steam now …uugghh

Ok so it’s done re-downloading everything but all of my content is gone and the tab for marketplace is grayed out. Any ideas?

*Edit - I had to turn on online content. Downloading all the content now

Well that’s apparently when mine started. Just like you I’ve never had any issues with CTD. It looks like the reinstall fixed it (so far). I’ve got about 30GB of content that’s downloading now so fingers crossed that won’t cause any issues

I reinstalled flight sim and updated to the latest Nvidia drivers…no joy. Constant crashes. I am trying a system restore from a state 2 weeks ago next

I assume you are possible affected in any kind from these issue: Playtime gone missing [Packages out of date]

Why you have to download 30 GIG, no idea…

please give more informations about what you have done, what happend, your system specs,… e.g. see similar to initial post.

The 30GB was the world updates and scenery downloads

ah… the additional content in-game ( content-manager )… I misunderstood your sentence :slight_smile:

No worries. Thanks for helping.

1 Like