CTD fresh install (Steam) CTD , HP Reverb, WMR, d3d11.dll, nvidia

Fresh Steam installation onto second SSD drive not C, fully updated Windows 10.

Crash to desktop without error message whilst running through pre-flight in VR, WMR Reverb G1.

Rebooted MSFS and after checking for updates it decides I need to download all the 155GB of installation data, again and then of course, the 3 major updates just for giggles, yet the folders containing the installation files were all where they should be and reported the right kind of size.

Nothing in my community folder either, this was a brand new fresh installation today, following a crash yesterday that also forced me to re-download all the content, which takes all day to complete!

So two whole days lost downloading the same files!

I’m going to try copying the packages folder onto a third drive tomorrow, so hopefully if this happens a third time, I can save another wasted day downloading the same files all over again.

I only bought the Sim last week. So far I’ve managed about 4 hours flight time and five whole days lost on installing it over and over again.

Please tell me there’s hope…

Just download the last STANDARD version update no matter what version you have. This seems to clear out something in the base code that is causing all the CTD problems. All 3rd party software and upgraded version planes and airports will still be there. Your graphic settings in the game will change and you will need to set them back to the way you had them before the update.

Hi. Thanks for the reply. Here comes the question…

I purchased the Premium version on Steam. How do I go about installing the Standard version?

Well, this is sad. Completed a fresh installation of MSFS onto D drive. Saved a copy of my entire flight sim folder onto a backup drive just in case, then tried running the sim again.

The good news is that despite it continually crashing to desktop, MSFS is not currently forcing a new download of all the content when I reboot the sim. The not good news is that it crashes to desktop every single time I attempt to fly. If I try a full checklist cold start then the crash happens before I begin to Taxi. If I skip all the pre-flight, and just cold start, the sim stays running perfectly until I reach the Runway.

So I’m not sure if it crashes at the same amount of run time, but it feels like it is always after about ten minutes.

My System Specs are 9700K, 32Gb Ram, RTX2080 Ti. Latest NVidia driver, windows fully up to date and OpenXR installed. I have tried both the developer and non developer XR check box too.

I have spent the last 4 hours solidly trying everything I can find on the internet, including increasing my page file from my usual 8Gb to 32Gb.

Last week I didn’t get a single crash in the circa four hours I flew around without issue, so I think this is related to the recent hotfixes/updates that happened over the weekend?

there is no difference at this point. With deluxe you can then download IN-GAME ( yes, it is not like a normal Steam game ) the additional content.

with or without VR… this is a huge diff for checking possible issues.

And… please check windows event log for possible entries.

Hi MichaMMA.

This is crashing using a HPReverb/WMR.

I’m lost now. Tried multiple NV Drivers, DDU clean installs, searched google and forums till my eyes bled.

Is it time to wipe my drive and start afresh?

This crash happened after spending the entire day sat changing/lowering settings etc, ensuring that my temps are good and FPS stays above 30 and is limited to below 50. Everything appears fine until, blam, it crashes after about ten minutes. I made it into the once last night. So there’s progress!

Faulting application name: FlightSimulator.exe, version: 1.14.6.0, time stamp: 0x60420b1c
Faulting module name: d3d11.dll, version: 10.0.19041.746, time stamp: 0xfc177b9d
Exception code: 0xc0000005
Fault offset: 0x000000000012e980
Faulting process id: 0x824
Faulting application start time: 0x01d726939860f7ae
Faulting application path: D:\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: C:\WINDOWS\SYSTEM32\d3d11.dll
Report Id: 80dd4c93-e7c2-4a98-981a-3ee3dd5185f3
Faulting package full name:
Faulting package-relative application ID:

thanks for reporting back :slight_smile:

you can use the ‘@’ in front of username, then user get messaged… like @P4330412P

So, it happens in case of VR, then topic should better move to #bugs-and-issues:virtual-reality

That

points very often to a GPU or gpu driver issue… ( at least not memory related :wink: ) ( one of many examples )

If you sure your 2080Ti does not overhead ( my is in 60° range ) … hmmm…

But in case of VR I’m also not so ‘involved’ . Some users report isssues with VR, but not reallly with the “d3d11.dll”.

Here is a search link, may be you can find something special for VR :
https://forums.flightsimulator.com/search?q=HP%20Reverb%20%23bugs-and-issues%20%20order:latest

Wipe’ing your drive and re-install all from scratch might be waste of time :slight_smile:

PS… might be good choice to change your heading with directly mention the keywords CTD , HP Reverb, WMR, d3d11.dll, nvidia

@MichaMMA

Thanks again. I’ll move my thread to VR

I think you may be right that a full wipe may be a waste of time. I’ve read so many posts where folks have done just that, to no avail.

Here’s a weird thing though. All my crashes have happened in the Cessna 172 (non Garmin version) and all my successful non-CTD flights have been in the Cessna 152.

Just for giggles, I decided to test the 152 today and what do you know, a full complete flight for over an hour, without a CTD.

Coincidence? Perhaps…

Im off to try the same flight in the 172 now…

1 Like

very interessting… all informations are important.

I not know about issues with my second love the “C 172 SH” , but who knows. I flew in last time mostly with the mooney m20 and only in 2D ( :frowning: ).

1 Like

one thing I have possible in mind… you can try the enable / disable HAGS…

It can bring bit better performance, but can also cause issues. So far I know, for VR it is recommend to enable.

@MichaMMA

I’ll try enabling HAGS and see if it helps. I have always had it turned off, based upon the few posts I’ve read about it. Perhaps it helps VR but hinders 2D?

I’ll report what happens. :slight_smile:

okay, you have it already disabled… hmmm… then I assume the issue is still another one.

but anyway… HAGS is the “new” hardware gpu scheduler which should bring better ‘performance’. But there is mostly no difference noticable and sometime it cause crashes ( also at me, but then whole windows ). But HAGS itself becomes more stable in last times for most users and If you enable it and all works fine, you can let it enabled ( I think in a near future, this becomes the default ).
Related to VR some users report better perf, but just try it out :slight_smile:

this was what I had in mind about HAGS and VR users…

( I completly forgot that :slight_smile: )

1 Like

@MichaMMA

I tried HAGS on today and my FPS was immediately dropped from 35/40 to 25/28, so I quickly turned it back off.

Checking event viewer today, it appears that I keep encountering this: # Display Driver nvlddmkm stopped responding and has successfully recovered

Searching the web I have decided to try adding a TdrDelay entry into my registry to see if that will help.

wow… so, this feature is still a kind of random ‘thing’ :slight_smile:

I seen this sometime… in my opinion many issues comes from the gpu drivers itself. AMD users have similar issues ( system mean that the gpu driver is crashed and restart it ) … hope the setting will help.

A question… have you some kind of pci-e energy save’ing to on ? ( e.g in extended windows energy settings ? )

@MichaMMA

All energy saving features in windows are off and max power at all times. I also regularly check USB devices in device Manager to ensure that Windows is not allowed to turn any of them off to save power. Annoyingly Windows often reapplies this power saving to them after updates.

I’m far from knowledgable on this, but that’s what reading the web is for right and chatting with helpful folks like you! :slight_smile: It does appear that if the you takes longer than next to zero time to do something, Windows treats it as if the you has crashed and restarts it? Apparently by adding this TdrDelay registry thing, we are asking Windows to give the GPL more time to do what it’s been asked to do, before considering it stalled?

At least that’s what I think I’m trying to do? I’m off to the Den now to see if it works…

1 Like

hmmm… yes, sometime… but not noticed since a while that this happens.

You can ( or should I better say ‘should’ ? ) also disable the windows-quick-start.

in my opinion a normal user, … no, better absolutly no user should need to change this value.
I thought this is a very old issue and may be it happens under very high load only. It is simple a protection that the ‘system’ try to detect that something not respond in time and then the system restart these “service”. So in theory your system stay usable. Possible there are real issue which cause that ‘not responding’ ( here >2seconds) or there are some other side-effects which cause that…

Important
These registry keys should not be manipulated by end users, or by applications outside of targeted testing or debugging during driver development.

:slight_smile:

( I also thought that e.g. HAGS made the situation better related to this issue, but seems not )

@MichaMMA

That Tdrdelay registry thing made no difference whatsoever, so I have now deleted it.

The situation remains the same. CTD CTD CTD

A full week of trouble-shooting every suggestion on the www all to no avail. :frowning: Thanks anyway for your input. I’m done for now.

Maybe wait till Sim Update 4 See if that helps

1 Like

:frowning:

in meanwhile there are some poeple which report ctd with VR gaming.

Unfortunately most do that in wrong categories ( and mix VR and none-VR together ) and so it is realy hard to find out possible “Similarities”, but what I seen for VR is mainly the vcruntime…dll and often HP… some users can play >4hours and run then into ctd, other can play only 20minutes.

For generally solutions I run in meanwhile out of ideas, but as said I not own VR glass. The d3d11.dll is a bit special, what I know about, but may be there is realy an issue and get fix in next update.

Other users tried a lot of different nvidia driver versions, but may be that this is also only waste of time ( but nvidia is still also far away from the old ‘quality’ ).

Very important is to not forget to create a ZenDesk Ticket and put all bug ‘logs’ on it.

1 Like