CTD on Sim Start

Chronology of events
Round 1

  1. Did a clean install after getting fed up with CTDs preventing sim launch
  2. Started sim - again CTD when it started checking for updates
  3. Created a new cloud profile
  4. Started sim in vanilla state - worked fine
  5. Added the addons to community folder, did a touch and go at Zurich with A3NX - all fine
  6. Now added Fenix a320 - got a CTD when sim started checking for updates
  7. Cleaned out the community folder and tried starting the sim - CTD at same point
  8. Did a reset on cloud profile with a command from zendesk - no effect

Round 2

  1. Created yet another cloud profile (3rd one this time)
  2. Started sim in vanilla state - worked fine
  3. Now added just the Fenix - no other addon
  4. Started the sim and again got a CTD when it started checking for updates as the sim starts
  5. Removed it and restarted the sim in safe mode - CTD at the same point again
  6. Now onwards, each time I start it, get the CTD when it starts checking for updates

Really lost now whether it is a problem with cloud profile corruption or something else.

1 Like

I’ve had these CTD’s since SU9. It doesn’t matter at all what I have in the community folder. It happens when it’s empty, it happens when there are some addons inside. And suddenly it works again for a few days. It’s starting to annoy me tremendously. I think it’s server issues…

I use MSFS over Steam.

You are lucky, it works sometimes. I haven used the sim ever since SU9, did a rennistall, if worked fine for a day and then back to square one. Uninstalled it again and now 100s of $$$ investment in hardware and software is useless. I was one of the greatest voteries of this sim but am now losing hope.

1 Like

Are you running Razer Cortex? I found the game boost causing CTD’s immediately on start up.

1 Like

Seems to be what’s causing mine.

Mine is a clean install minus all addons or 3rd party addons. Still got it prior to last update. Will do a reinstall in a couple of days, have been away for a week.

I installed MSFS Deluxe Premiere edition yesterday and unable to start without immediate CTD. Specs are: Ryzen AMD 3700X CPU and EVGA 3090 24Ghz GPU. Upon installation, the system recommended “ULTRA” graphics settings which I now regret having selected. Since I can’t even start, can I at least reset to MEDIUM? Should I delete and re-install as the repair option does nothing to correct whatever is wrong?

to be sure … I assume its a new install, without installed Mods… you was never able to start the game ?

At first would be good that you post the message from windows event log, with bit luck we get an idea.

Some users also helped to start the application with -FastLauch… others, in case of gpu issues, with limiting the fps in nvidia control panel. But sometime is also simple the EN Lang Pack not installed.
Here’s also a FAQ ('s) with steps you can try: https://flightsimulator.zendesk.com/hc/en-us/articles/360015893879-All-versions-Crashing-CTDs-issues-Checklist