CTD When Creating Manual Cache etc

Please tag your post with #pc and/or #xbox.

`Are you on Steam

Brief description of the issue:
Same as the issue below, closed for some reason?
Works on Medium and Low

CTD When Creating Manual Cache - Bugs & Issues / Resolved Bugs - Microsoft Flight Simulator Forums

Hi, has anyone else experienced an instant CTD when trying to download a new area to manual cache? Happens every time I try it.

I’ve been playing around with manual caching and rolling cache a lot lately and have made some discoveries. I was motivated to do this because I want to get MSFS up-and-running for my dad who does NOT have internet but has been simming since FS2004. My thinking was that I’ll install the sim at my place (I DO have internet) and then pre-cache a lot of areas I know he like’s to fly in so he’ll be all set with great aerial imagery. Well, that isn’t possible … sort of.

Here’s what I’ve discovered …

If you launch the simulator with internet connected and then cache an area (either manually or with rolling cache by flying the area initially) and then disconnect your internet (but don’t re-launch the sim) and then re-fly that same area … it works. Scenery looks great because it’s pulling in aerial imagery and photogrammetry from local cache.

If you launch the sim WITHOUT internet connected and then try to fly an area that has been pre-cached … it won’t work.

Seems there is a bug whereby the cached data is useless and will not be utilized IF the sim if not able to authenticate properly (with internet connection at launch).

Microsoft/Asobo … PLEASE fix this and allow legitimate owners of the sim to play it offline AND retain full functionality of pre-cached data.


In my case manual cache causes CTD whenever it starts to download any data

1 Like

This has been an issue since launch, and it also affects the rolling cache. This is a legitimate problem, however the issues noted in the original post (before the merge) were fixed with Sim Update 6, so it would be recommended to create a new thread instead.


Yes … I’ve repeated this in another “Manual cache” post. I’m going to try drawing as much attention to it as possible in the hopes I’m wrong and MAYBE there’s hope for offline users. But I don’t think there is. Microsoft’s dam need to authenticate screws everything up.

If there is no resolution from forum members I’m going to try opening up a Zen desk complaint to appeal for offline users everywhere.

1 Like

@Tex99999 @Kevster72 @eklester I do not get CTDs with the manual cache, so could you provide some information for me to try and reproduce the problem? For example, the area you’re trying to cache, photogrammetry enabled or disabled, the selected quality of the cache, the cache file size etc.

I see, but each bug report should be in its own thread for easier readability from the developers and for the voting system to work properly. The shifting camera (fixed), missing data (fixed) and CTDs are separate issues. You can just copy the original post you made and put it in a new thread.

And you should definitely send a Zendesk report as well, as it is the most direct way to report a bug to Asobo developers.

1 Like

I just tried to cache an area around London City airport on high settings (photogrammetry enabled), with a manual cache size of 15 gb and had a ctd.

I tried again with an empty community folder and also got a ctd.

The cached area was no where near large enough to fill the 15 gb size of the manual cache file.

Here is a screen shot of what I am trying to cache:

Every time I try to resume download the sim crashes.

I am also unable to increase the size of the manual cache file while this download is pending.

1 Like

Photogrammetry - yes
Area LFTZ and LIMJ
High def level
Rolling 100GB, Manual 100 GB
Used Manual - less than 1 GB
FYI went to resume last DWNLD = CTD again

1 Like

Thanks, I will make an attempt using the same parameters!

1 Like

I am managing to download manual cache areas but the sim must be in windowed mode and CPU fans to full.

After initiating the download the CPU goes to 100% and stays there. Needless to say, this is making my computer very unstable. It’s definitely not normal.

I attempted a fairly large high-quality cache over the two areas you listed (as well as the pattern around EGLC that tamalien posted above) and I still couldn’t get it to CTD. The only difference to your parameters was that I set the cache file size to 16GB, otherwise my SSD would get too close to full.

My guess is that the issue could be caused when the game is attempting to communicate to specific CDNs, and it might be worth using a VPN (several users have reported that this fixes issues like slow download speeds, looping packages and more). Not really sure what else could be causing this. It might also help to follow the official CTD instructions in here and here (the advanced steps seem a little much since this does not appear to be a user-specific issue).

1 Like

I am wondering also if there is a possibility marketplace add ons may have an influence on this.

For example, the London City area I tried to cache lies within the area for which I have installed ORBX’s London City airport and London City Landmarks. In particular, I am wiondering if the latter, with its probable exclusion polygons for photogrammetry, may be having an influence here. As these are market place purchases they are not in the community folder and I haven’t yet tried to cahce this area with these removed.

1 Like

That’s a good thought as well. The safe mode is supposed to disable all third-party content, including add-ons from the Marketplace, according to the FAQ. A CTD should trigger the safe mode prompt (as long as developer mode is disabled), which will allow you cache the area without having to uninstall the Orbx sceneries.

I had a chance to revisit this and after triggering the ctd for downloading the same area in London, with the same settings as before, I restarted MSFS and allowed it to start in “safe mode”.

Returning to the manual cache settings and clicking ‘resume’ on the download has indeed allowed it to progress without the initial ctd I was experiencing.

So it appears that some marketplace downloads can indeed interfere with this manual cache process and cause a ctd.

The download concluded successfully without a ctd :grin:

1 Like

Very good! Thanks for testing.

@Tex99999 Does starting in safe mode eliminate the CTDs for you as well?

Yes I have too. PC, no Steam
It occurs also on safe mode.
And also if Community is empty :face_with_symbols_over_mouth:

I have no idea how to start in safe mode :cry:

Today I pulled the plug on my internet connection to see what would happen with all the rolling and manual cache. I flew the same flight as I fly everyday although I was flying 250K at 3000 instead of the usual 300K at FL100 or FL 150.
IMHO (with Project Coastline scenery) It looked as good or better than with the streaming scenery. I could hardly tell where the PC scenery stopped (Ventimiglia) and the default took over. Tons of good looking Autogen. Of course I have Nice, Cannes and St Tropez airports installed.
Even landing in St Tropez ( I run daily service there lol) it looked better than I remember with the streaming running.
I’ll have to fly it again with the streaming but as far as I’m concerned, the streaming is marginal benefit which makes the cache (if it does anything at all) the same marginal benefit.

My experience has been that when MSFS crashes to desktop attempting a manual cache, the next time the sim runs I am prompted with a dialogue box telling me the sim closed down unexpectedly and I have two choices “safe mode” or “continue with normal mode”.

Selecting “safe mode” disables all community folder items and marketplace purchases. This may allow for the manual cache to proceed as intended if “safe mode” is selected as the option.

The next time MSFS runs, provided the sim was closed normally, there should be no more prompt for this choice and the sim should launch as normal.

1 Like