CTD When Launching a Flight

UPDATE: I re-installed on an NTFS drive and it seems to have resolved the issue. Didn’t realize the drive I originally installed it on was exFAT.


ORIGINAL POST:

Just got this game and finished install today (Steam on PC).

Everything has been optimized for my system. Loads up fine, menus run smooth.

When I go to the World Map and select my departure and arrival locations, I hit fly and it crashes to desktop. Every single time. I’ve tried different planes, different airports, lowered graphics settings, etc. I verified files on Steam. I reset my PC. Nothing helps, same crash at the same spot.

My Specs:
NVIDIA GeForce RTX 2060
AMD Ryzen 7 3700X 8-Core
16GB RAM
Windows 10

Any idea what the issue might be?

This is the error I get in Event Viewer every time:
image

Exact same issue here after a reinstall. I did a debug and found an Access violation when the Sim reads it’s own PID. Your event log looks like the same error.

I’ve tried all the fixes including windows updates, limiting to 39 fps etc, but I think it’s a wait for patch based on that error message, as it’s not us, so much as the code itself.

1 Like

Hi, my MSFS on start runs a black screen for 2-4sec than CTD, it was working Tuesday, now it wont even load. I updated windows, was running the latest graphic driver (I tried Nvidia 471.41 with the same result) checked the USA English, sync the time. reinstalled the xbow app. nothing has worked. Any suggestions, Dave

2 Likes

Hi, same here!
Using Intel i5-3570 and AMD Radeon R9, so I think it has nothing to do with the CPU or the graphic card. :man_shrugging:

1 Like

Have you sent through a formal bug report? Mine was taken under investigation, but extra submissions will hopefully help their investigation to give us a fix

CTD when laughing a flight on my Xbox series s I feel you

Same here (after todays hotfix) Never had any loading issues until today after this Hotfix. Every attempt the sim freezes when loading the flight. This happens almost immediately after I press the Fly button.
Community folder is empty, and restarted the Sim every time.

Yeah, doesnt look like this Hotfix has fixed the issue. I’ll be updating my ticket, I’d encourage others to do it as well :slight_smile: the more tickets that get raised, the more chance we can play the sim again

UPDATE:

I re-installed it on an NTFS drive and it’s working perfectly now. I didn’t realize the drive it was on was exFAT… I have about 30 games on there and they all work flawlessly. Flight Sim seems to be the only one that didn’t like it.

Hi there, I managed to fix this. After reinstalling the main game on C:\ and the content on F:\ and clearing both the roaming and local app data flight sim folders, and removing navigraph and oculus VR, this seems to have fixed mine.

I think the thing to try is having the game on C:\ or your system root.

I have CTD when shortly after press “ready to fly”. Basically I press “ready to fly” screen dims and follows by CTD. I tried everything, reinstalling MSFS completely, trying normal and safe mod, changing video drivers, deleting usercofig.opt file and so on. To make matter weirder there are only two 3rd party add on that actually don’t crash after pressing “ready to fly” - those are : PMDG DC-3 and Hype H-145. Every other stock or 3rd part aircraft causing CTD.
Really not sure what to make of it!

OK I solved my problem. I have TM Airbus stick and HoneyComb Bravo Quadrant. There was redundant control assignment on both controller that caused crash right after I press “ready to fly”. Perhaps this find may help you guys. Reset you controller and rebind all keys again. Make sure there is no duplicates on different controllers!