DA62 - Parking Brake engages at touchdown

As per the thread title, I seem to be having an issue with the stock DA62.

I’m working through the World Tour bush trips from gamer 4805 on flightsim.to, and the first 40 legs have been absolutely fine, with incredible routes and scenery.

But on the last couple of legs, the aircraft is suddenly engaging the parking brake the moment the MLG touches down, which is obviously not ideal and causes some unnecessarily hairy landings.

Nothing has changed in my control bindings, and checking the controls menu the only button assigned in relation to this is ‘Toggle Parking Brake’ which is on a button on the side of my Gunfighter.

Even if I delete this assignment, and use ‘Parking Brake On’ & ‘Parking Brake Off’ by assigning these to an up / down switch on my panels, the same thing happens.

It is not related to touchdown speed or rate of descent as far as I can tell - whether I thump it down or touch down incredibly gently, the same thing happens.

I can’t see any other controls or bindings that could affect this - all assists are off and set to Hard or Real Life, and I can’t see that there is any setting inside the aircraft itself which would cause this to happen. None of the other parking brake controls in the sim are assigned to any other button or switch on my panels or joystick.

Any ideas please?

Have you tried unassigning the parking brake from all controls, then leaving it like that for a flight? If it does it then, you will know it’s Niro being your controls doing it. If it still does it, then something else is causing it.

I haven’t, but that’s an excellent idea, thank you.

I will give it a go & report back…

1 Like

My Turtle Beach Velocity One does this randomly and for some reason some aircraft are more prone to it than others. To Clarify the buttons on the throttle quadrant are renown for random inputs and I have Park Brake Toggle assigned to one of them.

OK, managed to try a quick leg of the same bush trip after work yesterday. Ensured flight model is modern, double checked that all assists are off and everything is set to real life / hard, then went through all the controllers in my profile and unbound and deleted ALL brake settings, parking brake and regular wheel brakes included.

Came in for a smooth landing in the DA62, and from the in-cockpit view the parking brake engaged the second the MLG touched the tarmac. The NLG obviously thumped down pretty hard, and I came to a stop on the runway with the parking brake on. None of the controls I normally use for brakes / parking brake had any effect as you would expect, and I could only disengage it to taxi by moving the lever with the mouse.

I tried an additional flight in the same aircraft from my local airfield at Earls Colne with the same un-bound brake settings. Operating as a free flight rather than a planned bush trip, this time the parking brake did not engage on landing. Adding the ‘toggle parking brake’ control back to the button on my Gunfighter saw the parking brake engage and disengage only at my command, and another short flight with the brakes axis mapped again as well saw the wheel brakes and parking brake work exactly as I would expect on taxi, takeoff, landing and parking.

I think the issue is therefore something to do with the specific bush trip I’m flying, but I’m at a loss to understand it, or how to correct it. Any ideas would be gratefully received!

Hi Scet106,

Thanks for your thoughts, and I did wonder about that too. I have tried a few more flights with all brake controls unassigned and it is still happening on this particular bush trip, but not in any other scenario.

I use VKB controls, and the configuration software shows that all my buttons, axes, levers and switches are working properly, with no random on-off or semi inputs. The parking brake works normally in a free flight or on landing one of the discovery flights in another aircraft, so I’m sure it’s unrelated to the physical controllers.

I have no clue why any activity, third party or otherwise, would cause the parking brake to engage on touchdown. I have no idea how they could even achieve that. It’s easy to do with scripting in programs like SPAD, for example, but just the SDK?

What was the exact bush trip by name, the one on .to?

Yes, it’s this one:

World Sightseeing Tour - Bush Trips Part 3 - North America (East) for Microsoft Flight Simulator | MSFS

They have all been fine up to now, it’s just 40, 41 & 42, so far…

I’m downloading it at work now. I had forgotten how slow flightsim.to is, but I guess that is a small price to pay for free.

I don’t understand the context of 40, 41, and 42, but I guess these are individual legs somewhere in part 3? Which one should I fly to replicate?

Ah, I see, from the images on the website:


I’ll try that one. The page advised you could use other planes instead of the DA-62, and I wonder if you had tried that? Perhaps it is plane specific?

It finally downloaded, and I’ve opened part 40 in LNM. Quite a long flight.

Do you have the issue when landing at every single airport en route? So South Caicos to Pine Cay, for example?

Hi again,

Yes, I was talking about the legs within world tour #3. I can’t recall exactly if it happened right from the start of leg 40, but it has definitely been an issue with legs 41 and 42 right from the start.

I haven’t tried it with any other aircraft and as per above, the DA 62 in free flight mode from the world map does not have the issue - it is only happening on these bush trips, and it didn’t happen in parts 1 & 2 of the tour.

I think I’ll mention it to the gamer who uploaded them to .to, just in case anyone else has seen the same.

Did you get a chance to try one of these flights? I’d be interested to see if you’ve had the same issue, before I raise it with the uploader.

Sorry, not had the chance. I’ll hopefully take a look tonight. That is long leg, so I presume the first two island stops would be enough?

Yes, as far as I can see it’s doing the same at every single landing.

Thanks for taking a look, I really appreciate it.

1 Like

The very first landing, and it engaged the parking brake as soon as the main gear touched down. It even ended the flight automatically.

Thank you so much for checking it out!

It’s really strange - I did this whole series of flights a couple of years ago when they first became available, but I don’t remember if this happened at the time. Maybe there has been an update or something has changed.

I might mention it to the creator, but I’m glad it is a general issue rather than something I’m not aware of in my settings, which seems to be the case if it’s happened to others.

1 Like