DA62X Improvement Mod (SU5, v0.5.0.1,Sep 04)

Your comment about H135 and CJ4 is correct they do not work either! I will get in touch if I find a solution.

On the H135 we had had some users who are unable to fly it due to the WASM error encounted with the FADEC. Unfortunately nothing tried made any difference. Appears to be limited to just a few people.

You didn’t mention that you had the H135 mod. That mod installs things in other places on your computer besides the Community folder. You have to find ALL of the items installed by that and other mods and remove them.

The problem persists with or without H135 mod and removal of the respective installation files and other mods!

Even the hidden files?

Which hidden files? Please give an example? See also this post which I think may be a possible cause:

The files outside the Community folder that it installs.

This is totally false. H135 does not and cannot drop files outside your Community folder. The game has a supported feature where it compiles .wasm files from addons into a format it can then consume. But there is no control over this process, it’s not like running an EXE or even consuming a DLL. It’s sandboxed. The WT CJ4 and DA40NGX mods do the same thing. These files don’t impact other aircraft, and the module isn’t running when flying another aircraft.

1 Like

Doesn’t it compile custom code somewhere?

EDIT: Hmm, I’m very wary about installing free addons that haven’t been thoroughly tested and I haven’t had any of these strange issues with my install

Many thanks for your helpfulness davux3 and mdapol

Is that an error or is it intentional? Like “hey, like a real test pilot, you never know what’s gonna happen”?

Can you add the third seat cabin views? The just added middle seat options look great.

I did see some people mention that the plane completely sinks on short final when reducing power to idle. Seems like this might be how the actual plane behaves. Here’s a video showing that some power is kept until touchdown:

4 Likes

I remember watching this series, such a great set of videos.

2 Likes

I tried to use the DA60 with the GTN750 mod of PMS5. With this mod the FADEC of the DA60 will not load for me. After removing the mod everything is fine again. Posted this on the GTN750 page as well. Maybe one of you can look at this issue. Thank you!

Is there a GTN mod for MSFS? Is it compatible with the DA62?

Yes:

And it seems it is currently not compatible with the DA62.

My understanding is that mod is still in development. Probably shouldn’t use it with other addons until the developer verifies that it is compatible.

Sorry for any confusion I might cause. I know that the GTN750 is in beta version. And being not compatible with the DA62 refers to the DA62 mod of MrTommymxr only.

Exactly. The current version is a replacement of the G1000 MFD so any MOD that also changes something on the MFD will not the compatible. It is one or the other.
However, all that is not related to the MFD itself will work.